Support » Allgemeine Fragen » WP Update auf 6.3: Header-Navigation und Social-Media Links gehen nicht mehr

  • Hallo,

    ich habe ein Problem nach dem Update auf die Version 6.3. Vorher funktionierte die Website einwandfrei – jetzt habe ich eine zerschossene obere Navigationsleiste (Header) und die Social-Media Links im unteren Bereich sind verschwunden.

    Im Website-Editor werden sowohl die Navigationsleiste als auch die Social-Media Icons unten korrekt angezeigt.

    Ich habe ein Paar Änderungen in der Formatierung probiert, es bleibt jedoch bei den geschilderten Problemen.

    Ich weiß da nicht mehr weiter und wäre sehr froh, wenn mir hier ein Experte helfen würde.

    Herzlichen Dank schon mal für eine Idee oder eine sonstige Anregung oder Hilfe! Hans-Jürgen Esch aus Berlin

    • Dieses Thema wurde geändert vor 9 Monaten, 2 Wochen von eschberlin.
    • Dieses Thema wurde geändert vor 9 Monaten, 2 Wochen von eschberlin.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 30)
  • Hallo,
    lies doch bitte mal: Bevor du ein neues Thema (Thread) erstellst.

    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.

    Viele Grüße
    Hans-Gerd

    Thread-Starter eschberlin

    (@eschberlin)

    Hallo Hans-Gerd & liebe Grüße von mir!

    Freue mich von dir zu hören! Wie gewünscht der Website-Bericht:

    ` wp-core
    
    version: 6.3
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%category%/%postname%/
    https_status: true
    multisite: false
    user_registration: 1
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 3
    dotorg_communication: true wp-paths-sizes wordpress_path: /mnt/web606/c2/18/5138718/htdocs/STRATO-apps/wordpress_03/app
    wordpress_size: loading…
    uploads_path: /mnt/web509/c2/18/5138718/htdocs/STRATO-apps/wordpress_03/app/wp-content/uploads
    uploads_size: loading…
    themes_path: /mnt/web606/c2/18/5138718/htdocs/STRATO-apps/wordpress_03/app/wp-content/themes
    themes_size: loading…
    plugins_path: /mnt/web606/c2/18/5138718/htdocs/STRATO-apps/wordpress_03/app/wp-content/plugins
    plugins_size: loading…
    database_size: loading…
    total_size: loading… wp-active-theme name: Twenty Twenty-Three Child (twentytwentythree-child)
    version: 1.0
    author: the WordPress team
    author_website: https://wordpress.org
    parent_theme: Twenty Twenty-Three (twentytwentythree)
    theme_features: core-block-patterns, post-thumbnails, responsive-embeds, editor-styles, html5, automatic-feed-links, block-templates, widgets-block-editor
    theme_path: /mnt/web606/c2/18/5138718/htdocs/STRATO-apps/wordpress_03/app/wp-content/themes/twentytwentythree-child
    auto_update: Deaktiviert wp-parent-theme name: Twenty Twenty-Three (twentytwentythree)
    version: 1.2
    author: Das WordPress-Team
    author_website: https://de.wordpress.org
    theme_path: /mnt/web606/c2/18/5138718/htdocs/STRATO-apps/wordpress_03/app/wp-content/themes/twentytwentythree
    auto_update: Deaktiviert wp-mu-plugins (1) WordPress automation by Installatron: author: (undefined), version: (undefined) wp-plugins-active (4) Cookie Notice & Compliance for GDPR / CCPA: version: 2.4.9, author: Hu-manity.co, Automatische Aktualisierungen deaktiviert
    Limit Login Attempts Reloaded: version: 2.25.22, author: Limit Login Attempts Reloaded, Automatische Aktualisierungen deaktiviert
    MetaSlider: version: 3.35.0, author: MetaSlider, Automatische Aktualisierungen deaktiviert
    WPForms Lite: version: 1.8.3, author: WPForms (latest version: 1.8.3.1), Automatische Aktualisierungen deaktiviert wp-plugins-inactive (1) Akismet Anti-Spam: Spam Protection: version: 5.2, author: Automattic - Anti Spam Team, Automatische Aktualisierungen deaktiviert wp-media image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1692
    imagemagick_version: ImageMagick 6.9.12-90 Q16 x86_64 17868 https://legacy.imagemagick.org
    imagick_version: 3.5.1
    file_uploads: File uploads is turned off
    post_max_size: 128M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    imagick_limits:
    imagick::RESOURCETYPE_AREA: 8 GB
    imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    imagick::RESOURCETYPE_FILE: 192
    imagick::RESOURCETYPE_MAP: 4 GB
    imagick::RESOURCETYPE_MEMORY: 2 GB
    imagick::RESOURCETYPE_THREAD: 1
    imagick::RESOURCETYPE_TIME: 9.2233720368548E+18
    imagemagick_file_formats: 3FR, 3G2, 3GP, A, AAI, AI, APNG, ART, ARW, AVI, AVS, B, BGR, BGRA, BGRO, BMP, BMP2, BMP3, BRF, C, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FAX, FILE, FITS, FLV, FRACTAL, FTP, FTS, G, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, H, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, JNG, JNX, JPE, JPEG, JPG, JPS, JSON, K, K25, KDC, LABEL, M, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, O, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PS, PS2, PS3, PSB, PSD, PTIF, PWP, R, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCREENSHOT, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMV, WPG, X3F, XBM, XC, XCF, XPM, XPS, XV, Y, YCbCr, YCbCrA, YUV
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP
    ghostscript_version: not available wp-server server_architecture: Linux localhost 3.10.0-1160.83.1.el7.x86_64 #1 SMP Linux localhost 3.10.0-1160.83.1.el7.x86_64 #1 SMP Linux localhost 3.10.0-1160.83.1.el7.x86_64 #1 SMP
    httpd_software: Apache/2.4.57 (Unix)
    php_version: 8.0.29 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 240
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 128M
    php_post_max_size: 128M
    curl_version: 8.1.2 OpenSSL/1.1.1u
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    current: 2023-08-11T19:20:33+00:00
    utc-time: Friday, 11-Aug-23 19:20:33 UTC
    server-time: 2023-08-11T21:20:31+02:00 wp-database extension: mysqli
    server_version: 5.7.38-log
    client_version: mysqlnd 8.0.29
    max_allowed_packet: 67108864
    max_connections: 3000 wp-constants WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /mnt/web606/c2/18/5138718/htdocs/STRATO-apps/wordpress_03/app/wp-content
    WP_PLUGIN_DIR: /mnt/web606/c2/18/5138718/htdocs/STRATO-apps/wordpress_03/app/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    WP_DEVELOPMENT_MODE: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined wp-filesystem wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable wpforms version: 1.8.3
    lite: Mrz 8, 2023 @ 12:42pm
    upload_dir: Beschreibbar
    total_forms: 1
    total_submissions: 5

    Hallo,
    zur Navigation: Sieht das denn im Backend unter Design > Website-Editor > Navigation auch so desolat aus?

    zur Social-Media Icons unten: wenn man in der developer console (Aufruf mit F12) die Hintergrundfarbe auf weiß stellt, sieht man, dass die social icons da sind. Auch da die Frage: Wie sieht das im Backend aus?

    Viele Grüße
    Hans-Gerd

    Nachtrag:

    Ich habe das gerade mal kurz mit einem Style in dunklen Farbtönen (Style „Pech“ bei Twenty Twenty-Three) nachgebaut. Das sieht hier ganz gut aus.

    Hier ein Screenshot dazu (bei Klick auf das Bild, wird das Bild vergrößert):

    TT3 Footer

    Ich würde die Zeile mit in die Gruppe des footers packen. Das ist bei dir unterhalb des footers.

    Thread-Starter eschberlin

    (@eschberlin)

    Hallo Hans-Gerd,

    leider lassen sich hier Screenshots nicht anhängen (oder ich stelle mich zu doof an). Wollte damit zeigen was ich dann beschreiben hatte: im Editor sind die Probleme sowohl mit der Navigation als auch mit den Social-Media Icons nicht erkennbar; es sieht wie vorher aus und eben so, wie es soll. Die Position der Social-Media Icons sollte so bleiben wie ich sie ausgetüftelt hatte (wenn möglich).

    Herzliche Grüße, Hans-Jürgen

    Hallo,
    doch, das geht: Wie kann man hier Bilder in einen Forenbeitrag einfügen?.

    Viele Grüße
    Hans-Gerd

    Thread-Starter eschberlin

    (@eschberlin)

    Danke Hans-Gerd für den Hinweis!

    Dann also die Editor-Ansicht (in Ordnung, wie ich es gewohnt bin):

    Und hier das Ergebnis im Browser (Firefox, Edge, Chrom identisch):

    Vielen Dank an dich, Hans-Jürgen

    • Diese Antwort wurde geändert vor 9 Monaten, 2 Wochen von eschberlin.

    Hallo,
    ich kann mich daran erinnern, dass ich bei einer WordPress-Instanz auch mal genau dieses Problem hatte. Ich weiß leider nicht mehr, woran das gelegen hat und konnte das hier auch lokal nicht reproduzieren. Ich habe auch mal getestet, ob der leere Absatz-Block ganz oben dazwischen funkt. Macht er aber nicht – trotzdem solltest du den leeren Absatz-Block löschen. Dann habe ich wie du auch als umfassenden Block einen Zeilen- statt Gruppen-Block verwendet. Aber auch das ist an sich kein Problem. Das hatte ich auch nicht vermutet.

    Schau doch mal bitte in die developer console (Aufruf mit F12), ob da irgendwelche Fehler auftreten.
    Sonst wäre es vielleicht erst mal sinnvoll, wenn du eine neue Navigation erstellst.

    Zum Social-Icons Block: Schau bitte mal, ob die Icons angezeigt werden, wenn du den Social-Icons-Block gruppierst und dann die Hintergrundfarbe für den Gruppen-Block auf weiß umstellst. Den Block solltest du besser in den Footer packen.

    Viele Grüße
    Hans-Gerd

    Ich werfe mal ein paar Snippets hier rein

    Website-Bericht:
    WordPress automation by Installatron

    Aus
    https://www.strato.de/faq/server/Gibt-es-einen-Weg-Applikationen-schnell-und-einfach-beim-Aufsetzen-eines-Servers-mit-zu-installieren/

    Wenn Sie technische Fragen zu einzelnen STRATO Cloud Apps haben, wenden Sie sich bitte an unseren Technologie-Partner Installatron.

    Kurzum: Ich schließe daraus, dass du einen Cloud Server oder die Cloud App bei Strato gebucht hast.

    Jede STRATO Cloud App wurde für die meist genutzten Anwendungsszenarien optimiert und steht Ihnen in der aktuellsten Software-Version zur Verfügung.

    … was meistens bedeutet, die Apps sind nicht 1:1 identisch mit den Original-WordPress-Paketen.

    Trifft das Obige auf dich zu, solltest du den Strato-Support bemühen (obwohl … die verweisen ja auf Installatron).

    Thread-Starter eschberlin

    (@eschberlin)

    Hallo,

    habe mittlerweile die Navigation durch einfache Links ersetzt und damit zumindest dieses Problem halbwegs gelöst. Die Social-Media Icons werden im Editor korrekt angezeigt, nicht jedoch auf der Website. Ebenso gibt es Probleme mit Tabellen, auch hier weichen Editor-Darstellung und Website voneinander ab. Also leider massig Probleme mit der neuen Version.

    Also bin ich weiterhin für Hilfe dankbar!

    Herzliche Grüße aus Berlin, Hans-Jürgen

    Man kann nicht helfen, wenn kein Dialog stattfindet. Es wäre gut, wenn du auf meinen Beitrag oben einmal eingehen würdest.

    Das sieht aus wie die Installation mithilfe einer Strato-App, also musst du dich für weiteren Support an Strato wenden. Wir haben keine vergleichbare WordPress-Version und können die auftretenden Fehler nicht nachvollziehen.

    Thread-Starter eschberlin

    (@eschberlin)

    Hallo Angelika,

    tut mir leid nicht rasch reagiert zu haben. Ich probiere momentan einfach rum. Habe einen gewöhnlichen Webspace bei Strato (Hosting Pro) und schlechte Erfahrungen mit deren Hilfe gemacht (bin meist abgewimmelt worden).

    Herzliche Grüße, Hans-Jürgen

    Hallo,
    die Fragen von mir hattest du bis dato noch nicht beantwortet:
    „Schau doch mal bitte in die developer console (Aufruf mit F12), ob da irgendwelche Fehler auftreten.“

    Viele Grüße
    Hans-Gerd

    Thread-Starter eschberlin

    (@eschberlin)

    Stand jetzt geht die Navigation wieder (Theme Navigation durch einfache Links ersetzt). Was nicht funktioniert sind die Social Media Icons. Da werden unten im Header mittig nur zwei Punkte angezeigt statt der Logos. Die Links zu den Media-Seiten funktionieren. Die Galerie-Tabelle macht ebenfalls Probleme – hier ist die Rahmenbreite um die Bilder nicht größer zu bekommen (vorher war zwischen den Bildern ein merklicher Abstand eingestellt. Im Editor sehen die Icons sowie die Tabelle wir vorher aus.

    Nachtrag: Da strato immer mal gerne irgendwelche lustigen Ideen in der wp-config.php unterbringt, wäre auch günstig, wenn due die wp-config.php hier postest.

    Wichtig: Zugangsdaten und SALT-Keys solltest du vor dem Absenden aus der Antwort auf jeden Fall löschen.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 30)
  • Das Thema „WP Update auf 6.3: Header-Navigation und Social-Media Links gehen nicht mehr“ ist für neue Antworten geschlossen.