Support » Installation » WP Weiterleitung falsch angegeben

  • Gelöst garnelenshop

    (@garnelenshop)


    Hallo,

    ich habe heute WP mit Woo Commerce installiert.
    Da mich das gestört hat, das erst die Worpressseite erscheint und erst nach Klick auf den Button Shop, dann der Shop von Woo, dachte ich über die Startseiten und WO Weiterleitungen im Backend das zu umgehen.
    Also hab ich die beiden Vorgaben Startseite und WO Seite auf http://www.garnelen-shop.eu/shop geändert (vorher war http://www.garnelen-shop.eu eingetragen).
    Hatte gehofft das dadurch der WOO Shop auch direkt die Startseite ist.
    Nun komme ich nichtmehr in die Einstellungen da er die Links dadurch natürlich falsch weiterleitet. Anmeldung läuft ins leere (leitet auf den falschen Link weiter)und dadurch kein Zugriff auf das Backend.
    In welcher Datei kann ich das manuell auf dem PC wieder umschreiben?
    Oder war bisher die ganze Arbeit umsonst und ich muss neu aufspielen?

    Vielen Dank für euere Hilfe.

    LG
    Marco

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Und täglich grüßt das Murmeltier und keiner benutzt die Suchfunktion:

    da gibt es mehrere Möglichkeiten. Am einfachsten ist es, wenn du …

    entweder im Kundenmenü deines Webhosters die Datenbankverwaltung öffnest (üblicherweise über phpMyAdmin) und dort in der für WordPress genutzten Datenbank in der Tabelle wp_options die korrekten Einträge für die Felder siteurl und home einträgst.
    oder indem du per FTP in der Konfigurationsdatei wp-config.php mit einem geeigneten Code-Editor (z.B. VS Code oder Notepad++, beide kostenlos erhältlich) die Zeile define( ‚RELOCATE‘, true ); oberhalb von /* That’s all, stop editing! Happy blogging. */ einfügst. Danach solltest du dich über wp-login.php anmelden und unter Einstellungen > Allgemein die URL ändern können. Wurde der Eintrag korrigiert und die Einstellungen per Button aktualisiert, muss man sich erneut anmelden. Die Website sollte dann aber wieder funktionieren. Vorsichtshalber sollte nun noch die in der wp-config.phpeingefügte Zeile wieder entfernt oder die Konstante auf false gesetzt werden: define( ‚RELOCATE‘, false );

    Du solltest vor entsprechenden Änderungen in der von mir genannten Art auf jeden Fall eine Sicherung erstellen.

    • Diese Antwort wurde geändert vor 6 Monaten von bscu.

    Hallo,
    wie @bscu schon geschrieben hat: siehe auch hier
    Viele Grüße
    Hans-Gerd

    Thread-Starter garnelenshop

    (@garnelenshop)

    Hi,

    danke für die Antwort.
    An die Datenbank hatte ich gar nicht gedacht.. Nur ewig die Dateien durchsucht.
    Läuft wieder..
    Ist schon paar Jahre her als ich noch Joomla nutzte.
    WP ist eher neu für mich und muss mich da noch reinfinden.

    Hast du eventuell noch eine entsprechende Idee wie ich den Woo Shop als direkte Startseite bekomme? Das dieser durch http://www.garnelen-shop.eu direkt aufgerufen wird.

    Vielen Dank

    Hallo,
    bitte immer ein neues Thema beginnen und nicht an ein anderes Thema anhängen, siehe FAQ.

    Kannst du das aktuelle Thema dann bitte als gelöst markieren, wenn das Problem damit für dich behoben ist:
    Gelöst
    Die Option findest du rechts in der Sidebar. Danke.

    Viele Grüße
    Hans-Gerd

    Thread-Starter garnelenshop

    (@garnelenshop)

    Ja klar mache ich… Sorry

    Soll ich jetzt dafür nochmal ein neues Thema erstellen?
    Oder so lassen.

    Denke beim nächsten mal dran..

    Soll ich jetzt dafür nochmal ein neues Thema erstellen?

    ja bitte und ein neues Thema beginnen.
    Ich habe das Thema schon mal als gelöst markiert.

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Das Thema „WP Weiterleitung falsch angegeben“ ist für neue Antworten geschlossen.