Support » Allgemeine Fragen » XAMPP: Fehlermeldung beim Hochladen des Bildes

  • Gelöst moon7deaf

    (@moon7deaf)


    Hallo, nachdem das Bild im Bild-Block hochgeladen worden ist, erscheint folgende Fehlermeldung: „Das Verzeichnis wp-content/uploads/2023/04 kann nicht angelegt werden. Ist das übergeordnete Verzeichnis durch den Server beschreibbar?“ Dann ist das hochgeladene Bild verschwunden. Das Betriebsystem: MacOS Big Sur. Das Theme: Twenty-Twenty-One.

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Anonymous User 20597857

    (@anonymized-20597857)

    Ist das übergeordnete Verzeichnis durch den Server beschreibbar?

    und isses das?
    Ein Website-Bericht würde es zeigen … (s. bitte Foren FAQ)

    Genau genommen ist das kein WordPress-Problem 😉

    Hallo @moon7deaf,
    in der Tat sollte dir doch nach einigen Threads hier im Forum klar sein, dass wir ohne einen Website-Bericht kaum helfen können und nur Kaffeesatzleserei betreiben können. Fehlende Informationen (z. B. der angeforderte Website-Bericht) bedeutet für uns, dass wir unnötigerweise Zeit investieren müssen, weil wir nachfragen müssen. Da wir eine Handvoll Freiwilliger sind, die in unserer Freizeit Probleme von WordPress-Anwendern versuchen zu lösen, erwarten wir, dass du auch Zeit investiert und uns die notwendigen Infos sendest.

    Du findest den von @kurapika angesprochenen Bericht, der auch bei einer lokalen Instanz zur Verfügung steht, unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Lies bitte auch noch mal: Bevor du ein neues Thema (Thread) erstellst.

    Viele Grüße
    Hans-Gerd

    Thread-Starter moon7deaf

    (@moon7deaf)

    Hier ist der WordPress-Bericht:

    wp-core
    
    version: 6.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /index.php/%year%/%monthnum%/%day%/%postname%/
    https_status: false
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true wp-paths-sizes wordpress_path: /Applications/XAMPP/xamppfiles/htdocs/wordpress
    wordpress_size: loading…
    uploads_path: /Applications/XAMPP/xamppfiles/htdocs/wordpress/wp-content/uploads
    uploads_size: loading…
    themes_path: /Applications/XAMPP/xamppfiles/htdocs/wordpress/wp-content/themes
    themes_size: loading…
    plugins_path: /Applications/XAMPP/xamppfiles/htdocs/wordpress/wp-content/plugins
    plugins_size: loading…
    database_size: loading…
    total_size: loading… wp-active-theme name: Twenty Twenty-Three (twentytwentythree)
    version: 1.1
    author: Das WordPress-Team
    author_website: https://de.wordpress.org
    parent_theme: none
    theme_features: core-block-patterns, post-thumbnails, responsive-embeds, editor-styles, html5, automatic-feed-links, block-templates, widgets-block-editor
    theme_path: /Applications/XAMPP/xamppfiles/htdocs/wordpress/wp-content/themes/twentytwentythree
    auto_update: Deaktiviert wp-themes-inactive (2) Twenty Twenty-One: version: 1.8, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Two: version: 1.4, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert wp-plugins-inactive (2) Akismet Anti-Spam: version: 5.1, author: Automattic, Automatische Aktualisierungen deaktiviert
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg, Automatische Aktualisierungen deaktiviert wp-media image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 40M
    upload_max_filesize: 40M
    max_effective_size: 40 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, BMP
    ghostscript_version: not available wp-server server_architecture: Darwin 20.6.0 x86_64
    httpd_software: Apache/2.4.54 (Unix) OpenSSL/1.1.1s PHP/8.2.0 mod_perl/2.0.12 Perl/v5.34.1
    php_version: 8.2.0 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 120
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 40M
    php_post_max_size: 40M
    curl_version: 7.53.1 OpenSSL/1.1.1s
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true wp-database extension: mysqli
    server_version: 10.4.27-MariaDB
    client_version: mysqlnd 8.2.0
    max_allowed_packet: 1048576
    max_connections: 151 wp-constants WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /Applications/XAMPP/xamppfiles/htdocs/wordpress/wp-content
    WP_PLUGIN_DIR: /Applications/XAMPP/xamppfiles/htdocs/wordpress/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined wp-filesystem wordpress: not writable
    wp-content: not writable
    uploads: not writable
    plugins: not writable
    themes: not writable

    Ich sehe in diesem Bericht, dass der Ordner „wp-content“ nicht beschreibbar ist. Warum? Bei Windows 10 kein Problem. Hat das mit dem Datenschutz zu tun?

    Hallo,
    wie bereits vermutet: Die Rechte sind nicht korrekt:

    wordpress: not writable
    wp-content: not writable
    uploads: not writable
    plugins: not writable
    themes: not writable`

    Dateien sollten auf 644, Verzeichnisse auf 755 gesetzt sein. Warum das so bei dir ist, kann ich nicht sagen.

    Viele Grüße
    Hans-Gerd

    Thread-Starter moon7deaf

    (@moon7deaf)

    Wie auf 644 setzen? Ich bin ein macos-Anfänger.

    Dazu kann ich dir nicht viel sagen. Für die Entwicklung verwende ich Windows-Systeme.
    Über Google findest du allerdings einige Infos, z. B. hier.

    Thread-Starter moon7deaf

    (@moon7deaf)

    Ich habe in XAMPP die Zugriffsrechte des Ordners „wp-content“ von „Nur Lesen“ auf „Lesen & Schreiben“ geändert. Nun ist das Problem gelöst. Vielen Dank!

    Moderator Bego Mario Garde

    (@pixolin)

    Alternativ Local-WP verwenden.
    (Download ohne Registrierung unter https://localwp.com/releases/)

    Thread-Starter moon7deaf

    (@moon7deaf)

    Ist Local-Wp kostenlos? Gibt es sie auch in deutscher Sprache?

    Moderator Bego Mario Garde

    (@pixolin)

    Local-WP ist kostenlos und auch ohne Registrierung erhältlich, allerdings nur auf Englisch. Die verwendeten Begriffe beschränken sich aber auf ein paar Worte. Du brauchst keine umfangreichen Dokumentationen zu lesen.

    Wenn du damit nicht zurecht kommst, ist vielleicht DevKinsta eine Alternative. Das ist sehr ähnlich, läuft aber auf Deutsch.

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Das Thema „XAMPP: Fehlermeldung beim Hochladen des Bildes“ ist für neue Antworten geschlossen.