Support » Allgemeine Fragen » Youtube Videos werden nicht geladen

  • Hallo zusammen,

    ich betreibe diese Seite:

    http://canyoningallgäu.de/

    und habe seit neuestem (bereits ein paar Monate) das Problem, dass meine eingebetteten Youtube Videos nicht geladen werden. Dieses Problem tritt sowohl im FF, als auch im Chrome & Safari auf. Wenn die Seite aber refrehed wird, bzw. neu geladen wird, tauchen die Clips auf.

    Könnt ihr mir einen Tipp geben, warum die Videos nicht direkt geladen werden?

    Danke und Grüße

    • Dieses Thema wurde geändert vor 3 Jahre, 4 Monaten von chrisslemke.
Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Abgesehen davon, dass du eine veraltete WordPress-Version nutzt und am besten direkt eine Aktualisierung vornehmen solltest, bräuchten wir von dir ein paar Angaben zu deiner Website.

    Hast du mal versucht, die Plugins vorübergehend zu deaktivieren, um sie als mögliche Fehlerquelle auszuschließen? Verwendest du ein Sicherheits- und/oder Cache-Plugin? Hast du zur Absicherung deiner Website besondere Einträge in der Server-Konfigurationsdatei .htaccess?

    Leider bereiten auch Umlaute in der Domain immer wieder Probleme.

    In Deinem CSS befindet sich folgende Regel:

    .main-content iframe[src] {
        opacity: 0;
    }

    Diese bewirkt, dass das Video vorhanden, aber nicht sichtbar ist. Bei einem Refresh Deiner Seite wird diese Regel überschrieben (ich weiß jedoch nicht woher) und dann sind die Videos wieder sichtbar.

    Empfehlung:

    Obige Regel in Deinem Child-Theme-Stylesheet zu

    .main-content iframe[src] {
        opacity: 1;
    }

    abändern.

    • Diese Antwort wurde geändert vor 3 Jahre, 4 Monaten von elschnuppero. Grund: typo
    • Diese Antwort wurde geändert vor 3 Jahre, 4 Monaten von Torsten Landsiedel. Grund: Code als Code ausgezeichnet

    Sieht so aus, als ob das Theme eine eigene Lazy Loading Funktion mitbringt (wozu würde es sonst alle iFrames aus dem main content ausblenden).

    Daher vermute ich, dass es einen Konflikt mit dem Lazy Load Plugin gibt, was du nutzt:
    https://de.wordpress.org/plugins/bj-lazy-load/

    Ich sehe allerdings keine Fehler in der Konsole. Ich würde aber trotzdem mal ein Deaktivieren des Plugins probieren.

    Gruß, Torsten

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Das Thema „Youtube Videos werden nicht geladen“ ist für neue Antworten geschlossen.