Support » Allgemeine Fragen » Zeitverzögerung auf passwortgeschützten Seiten

  • Hallo zusammen,
    seit ein paar Tagen suche in nun schon – unter anderem in diesem Forum – nach einer Lösung für mein Problem.
    Ich habe eine Seite mit einem Passwort geschützt. Klappt so weit. Doch wenn ich die Seite aufrufe und das Passwort eingebe, dann gibt es offenbar eine Zeitverzögerung, bis die Inhalte abgerufen werden können. Außerdem man muss die Seite nach etwa einer Minuten neu laden, bis die Inhalte auftauchen.
    Kann ich diese Zeitverzögerung irgendwo einstellen? Oder liegt es vielleicht an etwas ganz anderem, was ich nicht auf dem Schirm habe?
    Ich würde mich über konstruktive Rückmeldungen sehr freuen.
    Viele Grüße, Stephan

    Infos:
    Die Seite: https://stephano.eu/testseite/
    Die habe ich extra hier zum Testen eingerichtet 🙂
    Das Passwort: hallo

    Website-Zustand:

    version: 6.0
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: -1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /kunden/508399_50676/wordpress/wordpress
    wordpress_size: 50,79 MB (53254455 bytes)
    uploads_path: /kunden/508399_50676/wordpress/wordpress/wp-content/uploads
    uploads_size: 18,09 MB (18973134 bytes)
    themes_path: /kunden/508399_50676/wordpress/wordpress/wp-content/themes
    themes_size: 1,69 MB (1774902 bytes)
    plugins_path: /kunden/508399_50676/wordpress/wordpress/wp-content/plugins
    plugins_size: 61,91 MB (64913745 bytes)
    database_size: 60,51 MB (63450523 bytes)
    total_size: 192,99 MB (202366759 bytes)
    
    ### wp-active-theme ###
    
    name: Twenty Twenty (twentytwenty)
    version: 2.0
    author: WordPress-Team
    author_website: https://de.wordpress.org/
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, custom-background, post-thumbnails, custom-logo, title-tag, html5, align-wide, responsive-embeds, customize-selective-refresh-widgets, editor-color-palette, editor-font-sizes, editor-styles, widgets, menus, editor-style
    theme_path: /kunden/508399_50676/wordpress/wordpress/wp-content/themes/twentytwenty
    auto_update: Deaktiviert
    
    ### wp-plugins-active (6) ###
    
    Allow ePUB and MOBI formats upload: version: 1.0, author: eKnizky.sk, Automatische Aktualisierungen aktiviert
    Borlabs Cookie - Cookie Opt-in: version: 2.2.53, author: Borlabs GmbH, Automatische Aktualisierungen deaktiviert
    Google Analytics for WordPress by MonsterInsights: version: 8.6.0, author: MonsterInsights, Automatische Aktualisierungen aktiviert
    miniOrange 2 Factor Authentication: version: 5.5.78, author: miniOrange, Automatische Aktualisierungen aktiviert
    Really Simple SSL: version: 5.3.2, author: Really Simple Plugins, Automatische Aktualisierungen aktiviert
    UpdraftPlus - Backup/Restore: version: 1.22.12, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1692
    imagemagick_version: ImageMagick 6.9.12-52 Q16 x86_64 17273 https://legacy.imagemagick.org
    imagick_version: 3.7.0
    file_uploads: File uploads is turned off
    post_max_size: 75M
    upload_max_filesize: 50M
    max_effective_size: 50 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 59 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 786432
    	imagick::RESOURCETYPE_MAP: 59 GB
    	imagick::RESOURCETYPE_MEMORY: 29 GB
    	imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, AVI, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, H, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: 2.3.3
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.0-1160.62.1.el7.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.4.30 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1500
    time_limit: 60
    memory_limit: 128M
    max_input_time: 60
    upload_max_filesize: 50M
    php_post_max_size: 75M
    curl_version: 7.61.1 OpenSSL/1.1.1k
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.4.25-MariaDB
    client_version: mysqlnd 7.4.30
    max_allowed_packet: 64000000
    max_connections: 400
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /kunden/508399_50676/wordpress/wordpress/wp-content
    WP_PLUGIN_DIR: /kunden/508399_50676/wordpress/wordpress/wp-content/plugins
    WP_MEMORY_LIMIT: 128M
    WP_MAX_MEMORY_LIMIT: 128M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 17)
  • Ich kann das Problem nicht reproduzieren.

    Die passwortgeschützte Webseite wird in rund 450ms geladen.
    Nach Eingabe des Passworts wird die Webseite in rund 650ms geladen, wobei die erhöhte Ladezeit durch den zusätzlich geladenen Inhalt in Ordnung geht.

    Thread-Ersteller zwirner92

    (@zwirner92)

    Vielen Dank für deine Rückmeldung.
    Das scheint in den unterschiedlichen Browsern unterschiedlich lange zu dauern. Bei mir dauert es tatsächlich bei allen Browsern ein bis zwei Minuten …

    Auch das kann ich – zumindest für Firefox und Chrome – nicht bestätigen.
    Sowohl die passwortgeschützte Seite als auch der freigegebene Inhalt laden mit sehr guter Performance unter 1 Sekunde.

    Danach konnte ich nicht weitertesten, weil du Änderungen an der Website vorgenommen hast.

    Thread-Ersteller zwirner92

    (@zwirner92)

    Ich habs jetzt noch mal in allen Browsern auf dem Rechner (Mac) und dem iPhone 7 probiert und das Problem bleibt bestehen 🙁

    Thread-Ersteller zwirner92

    (@zwirner92)

    Ich habe an der Website nichts geändert …

    Und jetzt? ¯\_(ツ)_/¯

    Thread-Ersteller zwirner92

    (@zwirner92)

    Tja, das ist die Frage. Ich bin ratlos …

    Deaktviere mal das Cookie-Plugin und teste dann nochmal.

    Gibt es einen Grund, wieso du Really Simple SSL verwendest? Wenn du richtig auf HTTPS umstellst, brauchst du das nicht.

    Hast du die URL mit https eingegeben?

    Thread-Ersteller zwirner92

    (@zwirner92)

    Was meinst du mit „richtig auf HTTPS umstellen?“ Ich habe bei meinem Hoster ein Zertifikat bestellt (und bekommen) und dachte, ich bräuchte dann für die saubere Einstellung noch dieses Plugin.

    Die URL habe ich richtig eingegeben.

    Die Deaktivierung des Cookie-Plugins bringt leider keine Verbesserung.

    Hallo,

    ich bräuchte dann für die saubere Einstellung noch dieses Plugin.

    Sicher nicht, weil das Plugin an sich eher eine Krücke ist.

    Eine saubere Umsetzung ist ohne Plugin auf jeden Fall möglich. Seit WordPress 5.7 kann man die Umstallung von http auf https sogar über Werkzeuge > Website-Zustand machen – vorausgesetzt man hat ein SSL-Zertifikat. In der Regel funktioniert das wunderbar. Sollte dann noch mixed content (Auslieferung über http statt über https) auftauchen, kann man z. B. über die Seite whynopadlock prüfen, wo möglicherweise noch Restarbeiten notwendig sind. Mit einem Plugin wie z. B. Better Search and Replace kann man Korrekturen in der Datenbank in Bezug auf Mixed Content vornehmen.
    Das Plugin Better Search and Replace kann danach dann wieder gelöscht werden.

    Das ist dann eine saubere Sache ohne ein Plugin.

    Aber das hat alles jetzt eher nichts mit deinem Ausgangsproblem zu tun.

    Du kannst ja mal nach einer Sicherung das Plugin Health Check & Troubleshooting installieren. Anschließend kannst du unter Werkzeuge > Website Zustand unter Problembehandlung auf den Button „Problembehandlungsmodus aktivieren“ klicken. Dann werden alle Plugins deaktiviert und als Standardtheme z. B. Twenty Twenty-One aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann zunächst das Theme von dir und danach Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise herausfinden, ob das Problem durch das Theme und/oder ein Plugin verursacht wird. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und Plugins sieht, während nur für dich alle Plugins deaktiviert sind.

    Viele Grüße
    Hans-Gerd

    Thread-Ersteller zwirner92

    (@zwirner92)

    Vielen dank für deine ausführliche Antwort.

    Den Aspekt SSL habe ich jetzt kapiert und umgesetzt. Danke!

    Für die geschützte Seite funktioniert dein Ansatz leider nicht, denn sobald ich eingeloggt bin, bekomme ich die Inhalte der Seite ja sowieso vollständig angezeigt und kann gar nicht auf die Passworteingabe zugreifen. Und über einen anderen Brwoser greife ich dann ja wieder auf die Seite ohne Problembahandlungsmodust zu. Oder bin ich einfach nur zu blöd dazu? 🙂

    Ich glaube auch nicht, dass das Plugin Health Check hier hilfreich ist.

    Hast du mal probiert, wie sich die Website in „privaten Browser-Fenstern“ (auch „Inkognito-Modus“ genannt) verhält?

    Thread-Ersteller zwirner92

    (@zwirner92)

    Auch inkognito das gleiche. Ich bin etwas irritiert, weil du die Seite schnell mit dem Passwort öffnen konntest. Ich habe es mittlerweile auch auf anderen Geräten und in anderen Netzwerken versucht, ohne Änderungen.
    Können denn alle anderen die Seite öffnen?

    Das kann natürlich auch mit deinen Cookie-Einstellungen zusammenhängen. Um das eingegebene Passwort zu speichern, setzt die Webseite ein Cookie. Hast du die Speicherung von Cookies durch Browser-Vorgaben oder Auswahl im Cookie-Banner unterbunden, kann der Passwortschutz nicht aufgehoben werden.

    Viel mehr föllt mir dazu leider nicht ein – bei mir funktioniert das Auflösen des Passworts auf der Webseite wie gesagt völlig reibungslos.

    Thread-Ersteller zwirner92

    (@zwirner92)

    Ich habe jetzt mal über Facebook Freunde gebeten, die Seite zu öffnen. Das Ergebnis ist:
    – bei einigen kommt die Passwortabfrage und nach sehr Eingabe öffnet sich alles wie gewünscht.
    – bei einigen kommt die Passwortabfrage, aber es passiert nach der Eingabe nichts.
    – bei einigen öffnet sich dieser geschützte Inhalt sofort.

    Da scheint also irgendwas im Argen zu sein. Ein Muster ist nicht erkennbar und der Prozess ist auch nicht reptroduzierbar.

    Gibt es eine Alternative Möglichkeit zu Sicherung einzelner Seiten durch ein Passwort? Beispielsweise ein gutes Plugin? Hat hier jemand eine Idee?

    Grüße und ein schönes Wochenende,
    Stephan

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 17)