Support » Allgemeine Fragen » Zerschossen nach URL-Änderung

  • Gelöst sunny07

    (@sunny07)


    Hallo,

    leider habe ich mich auch dumm angestellt, habe in Einstellungen die Seite xxx auf Seite xxx/shop … geändert. Nachdem die Seite nicht mehr richtig angezeigt wurde, habe sofort wieder den Zusatz shop entfernt und bin auf speichern, doch da war es vorbei und ich komme nicht mehr ins Dashboard.

    Wie bei einem anderen Beitrag beschrieben, habe ich in der in der config.php ergänzt:
    define( ‚RELOCATE‘, true ); trotzdem komme ich nicht rein: Beim Anmeldeversuch springt die URL ständig von https://www.domain.de/wp-login.php auf https://www.domain/shop.de/wp-login.php und die Website bleibt nicht erreichbar.

    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß beim Bloggen. */
    define( ‚RELOCATE‘, true );
    /* That’s all, stop editing! Happy blogging. */

    Was tun?

    Vielen Dank schon mal für eure Hilfe!

    Barbara

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Die sicherste Variante ist ein Backup einzuspielen.

    Vielen Dank für die schnelle Antwort!

    ich habe jede Menge Datenbankbackups; das Backup der config.php ist vom März 2019 (peinlich …) – damit ging es nicht.

    Also anderer Versuch: Ich habe in die config.php diese zwei Zeilen eingegeben:

    define(‚WP_SITEURL‘, ‚https://www.meinedomain.de‘);

    define(‚WP_HOME‘, ‚https://www.meinedomain.de‘);

    Jetzt geht es wieder – allerdings wird davor in einem Beitrag gewarnt. Bessere Idee?

    Vielen Dank für eure Unterstützung!

    Barbara

    … und etwas später aus heiterem Himmel dieses neue Problem:

    Es funktioniert nur noch die Startseite. Alle Beiträge … Impressum … sind im Frontend nicht erreichbar, Fehlermeldung:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at webmaster@meinedomain.de to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    Apache Server at http://www.meinedomain.de Port 443

    Inzwischen habe ich auch eine aktuelle Datensicherung über meinen Hoster. Das Einspielen der aktuellen config.php hat nicht geholfen. Sorry die Anfängerfrage: Welche Datei am besten wiederherstellen? Jede einzeln?

    LG Barbara

    ————————————————
    Hinweis von Moderator
    ————————————————
    Bitte keine E-Mail-Adresse veröffentlichen!

    Hallo,
    ich habe gerade die Webseite getestet – bei mir tauchten keine Probleme auf. Evtl. mal den Browsercache löschen oder Seite in einem anderen Browser öffnen.
    Oder hat sich das Problem mittlerweile erledigt. Wenn ja, dann bitte das Thema als gelöst markieren.
    Viele Grüße
    Hans-Gerd

    Danke!

    … und wie hast Du das Problem gelöst ?

    Hm, ich weiß nicht, ob es wirklich gelöst ist. Ich wollte den Beitrag nicht offen lassen, weil ich ein paar Tage nicht da bin.
    Beim ersten Crash hatte ich mir durch den Eintrag in der wp-config.php gehofen:
    define(‚WP_SITEURL‘, ‚https://www.meinedomain.de‘);
    define(‚WP_HOME‘, ‚https://www.meinedomain.de‘);
    Der Eintrag ist noch drin, sonst komme ich nicht rein. Ich befürchte aber, dass das keine Dauerlösung ist. Denn für den 2. Crash aus heiterem Himmel habe ich sonst keine Erklärung.
    Den 2. Crash habe ich gelöst, indem ich ein Backup der htaccess aufgespielt habe. Seither
    geht wieder alles.
    Nun überlege ich, ob ich nach den Feiertagen alle Systemdateien aus dem Backup neu aufspielen sollte. Was meinst du?

    Gelöst! – Glaube ich:

    In der Datenbank konnte ich die falschen URLs ändern: Dazu habe ich mich bei meinem Hoster im phpMyAdmin eigeloggt und bin auf wp-options gegangen. Dort konnte ich unter option_name und option_home die falsche URL ändern.

    Dann habe ich aus der config.php die beiden Zeilen

    define(‘WP_SITEURL’, ‘Adresse der neuen Domain’);
    define(‘WP_HOME’, ‘Adresse der neuen Domain’);

    wieder gelöscht und meine Seite funktioniert immer noch.

    danke für Info – freut mich, dass es wieder klappt 🙂

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Das Thema „Zerschossen nach URL-Änderung“ ist für neue Antworten geschlossen.