Support » Allgemeine Fragen » Zugriff Verweigert Error 403 nach ein paar Tagen ohne was getan zu haben

  • Gelöst taank

    (@taank)


    Hallo zusammen.

    Ich hab vor ein paar Wochen ein Portfolio mit meinen Projekten auf eine Website gebracht und veröffentlicht. Die Seite lief mehrere Tage reibungslos und man konnte die Seite von jedem Gerät öffnen und ansehen. Aber seit heute, 14.06.2020, bekomme ich diesen Fehler:
    „Forbidden
    You don’t have permission to access this resource.“

    Egal ob ich die Seite aufrufen möchte oder in den /wp-admin bereich möchte. Seit drei oder vier Tagen wurden keine Änderungen mehr daran vorgenommen.
    Das alles hab ich versucht:
    -.htaccess ändern und löschen
    – plugins deaktivieren
    – berechtigungen gecheckt (ordner sind auf 755 und Dateien auf 644)

    Mir ist beim Durchschauen meiner Installation aufgefallen, dass ich gar keine wp-config habe. Aber sowohl die Datenbank als auch das WP wurden frisch aufgesetzt.

    Ich habe ein Theme von Themeforest gekauft und das ließ sich auch Problemlos installieren. Nur bei der Installation der Plugins war ein Fehler bei jedem Plugin. Dennoch ließen sich die Plugins installieren und bearbeiten, beziehungsweise konfigurieren.

    Falls ihr weitere Infos benötigen solltet, lade ich die gerne dann hier hoch.

    Beste Grüße,
    Kemal

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Da ist so ziemlich alles möglich von Bedienungsfehler bis Website gehackt. Außerdem ist es mit dem Hinweis „Website ist kaputt“ alleine auch schwierig zu beurteilen.

    Schau doch mal per FTP-Programm nach, was für Dateien überhaupt noch vorhanden sind. Ein Fehler 403 – Forbidden wird z.B. ausgegeben, wenn in einem Verzeichnis keine index.php oder index.html gefunden wird und ein Listing des Verzeichnisinhalts aus Sicherheitsgründen verboten ist. Fragt sich dann nur, wieso diese Datei nicht da ist. Dass es keine wp-config.php gibt, ist ebenfalls nicht normal.

    Vielleicht hat dein Webhoster ein Backup, dass du wiederherstellen kannst?

    Thread-Starter taank

    (@taank)

    Danke für die fixe Antwort.

    wp-content
    wp-includes
    wp-admin
    wp-comments-post.php
    readme.html

    Die ersten drei Ordner und die beiden Dateien unten sind im Obersten Ordner vorhanden. Da sollte ja eigentlich auch die index File und die wp-config sein oder? Ich kann den Fehler nicht reproduzieren, daher hab ich jetzt das Backup einspielen lassen vom Hoster. Ist zwar älter als ich gehofft hatte, aber dann sehe ich mal ob bei dem alle Daten vorhanden sind.

    Das ist in der Tat ein bisschen wenig an Dateien.
    Fragt sich, wer die gelöscht hat. ¯\_(ツ)_/¯

    Dateien löschen und Backup wiederherstellen wird die sauberste Lösung sein.
    Anschließend Zugangsdaten austauschen, alles aktualisieren und eigenes, regelmäßiges Backup erstellen.

    Thread-Starter taank

    (@taank)

    Schon merkwürdig. Aber nagut. Das ist jetzt getan und ich achte mal darauf, wer Zugriff haben sollte.

    Thread-Starter taank

    (@taank)

    Hi @pixolin

    es ist schon wieder passiert… ich habe alle Passwörter geändert und ein cleanes Backup einspielen lassen. Es hat gestern noch alles funktioniert, aber heute nicht mehr… Es sind wieder alle Dateien gelöscht. Also index und wp-config. Weißt du eventuell weiter? Was kann ich an Infos weitergeben, damit man mir helfen kann?

    Gruß,
    Kemal

    Es kann sein, dass dein wiederhergestelltes Backup bereits eine Backdoor (eine versteckte Zugriffsfunktion für Angreifer) enthielt. Die Zugangsdaten hattest du gleich nach Wiederherstellung geändert, wie ich es vorgeschlagen hatte? Vielleicht sprichst du nochmal mit dem Support deines Webhosters.

    Eine manuelle Beseitigung von Malware ist aufwendig, aber durchaus machbar. Eine Anleitung dazu habe ich hier vor einer Weile geschrieben. Wenn du nicht lange suchen magst, findest du sie hier: https://pixolin.de/arbeitsschritte-reparatur-gehackte-website/

    Thread-Starter taank

    (@taank)

    Genau, die Daten habe ich direkt nach dem Backup geändert. Ich hab dem Webhoster mal ne Mail geschrieben und warte gerade auf eine Antwort.

    Ich geh mal deine Anleitung durch. Danke!

    Gerade nach einer Reinfektion nach Backup Wiederherstellung macht eine Log Analyse umso mehr Sinn. Die zeigt evtl. bereits im Backup enthaltene Schaddateien auf.

    Empfehlenswert ist auch die Einrichtung der NinjaFirewall im Full WAF Mode.
    Ich persönlich sorge auch dafür, dass nicht benötigte Dateiaufrufe in /wp-content gar nicht erst möglich sind.

    Das kann man auf Apache Servern mit dieser .htaccess Vorlage erreichen.


    Moderationshinweis: Vorsorglich der Hinweis, dass Job-Angebote jeglicher Art im Support-Forum unerwünscht sind. „Ich persönlich sorge auch dafür …“ könnte da missverstanden werden. Viele Grüße, Bego

    • Diese Antwort wurde geändert vor 2 Jahre, 7 Monaten von Bego Mario Garde.
    • Diese Antwort wurde geändert vor 2 Jahre, 7 Monaten von Bego Mario Garde. Grund: Moderationshinweis
    Thread-Starter taank

    (@taank)

    Hi zusammen, ich hab vom Webhoster jetzt die Bestätigung erhalten, dass alles auf Werkszustand gesetzt wurde. Ich habe wieder mein Theme hochgeladen und die benötigten Plugins installiert. Diese Meldung kam auf:

    „Warning: sprintf(): Too few arguments in /www/htdocs/w0126505/kemalamet.de/wp-admin/includes/class-bulk-upgrader-skin.php on line 152“

    Ich versuche jetzt mal die Seite wieder so einzurichten wie es vorher war und dann seh ich mal ob die erneut gelöscht wird.

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Das Thema „Zugriff Verweigert Error 403 nach ein paar Tagen ohne was getan zu haben“ ist für neue Antworten geschlossen.