Verfasste Forenbeiträge

Ansicht von 2 Antworten – 1 bis 2 (von insgesamt 2)
  • Thread-Starter brixjust4me

    (@brixjust4me)

    Nun ist es eine Woche her und ich melde mich noch einmal um das Thema vielleicht auch für die Nächsten abschließen zu können.

    Es hat alles geklappt. Ich habe mir die Artikel die ihr verlinkt habt durchgelesen, selbst noch ein wenig recherchiert über den Zusammenhang der Datenbanken und nachdem ich nur sehr wenig verstanden habe… habe ich einfach den Rat von Michi91 befolgt!

    Bei mir konnte ich den Down- und Upload umgehen, indem ich die Dateien auf Plesk in neue Ordner verschoben und dort den CleanUp vollzogen habe. Ablauf war wie folgt:

    1. Neuen Ordner mit wildem Namen erstellen, damit man ihn nicht verwechselt.
    2. Frisches WordPress von der WordPress-Seite runterladen und in den neuen Ordner hochladen (letzteres dauert EWIG… auch wenn es nur wenige MB sind)
    3. Aus meinem originalen Seiten-Ordner alles aus dem wp-content-Ordner außer Plugins und Themes in den neuen Ordner an die gleiche Stelle kopieren und den vorhandenen (Roh-)Inhalt ersetzen
    4. Aus meiner langen Liste an Plugins die wichtigsten 5 raussuchen (WooCommerce etc), diese jeweils von der WordPress Plugin-Seite herunterladen und dann in den Plugins-Ordner laden (EEEEEEWIG)
    5. Das gleiche auch mit dem Theme in den Theme-Ordner
    6. Alles aus meinem Original-Ordner (der hinter der Seite liegt) in den Papierkorb legen
    7. Den Inhalt des neuen Ordners in den Original-Ordner kopieren
    8. Fertig!

    Zu Anfang kam es noch zu Permalink-Problemen. Also wenn man auf der Seite im Frontend auf irgendwas geklickt hat, kam die Fehlermeldung „404 Serverfehler, Seite konnte nicht gefunden werden“ – bei jedem Link oder Produkt. Dies konnte gelöst werden, indem wir bei einem einzigen random Produkt und bei jeder einzelnen Seite (Warenkorb, Impressum, AGB, etc.) einmal im Backend auf „Aktualisieren“ geklickt haben (ohne einen Seiteninhalt zu ändern). Dadurch wurde der Link neu verknüpft und die Seite lief im Frontend wie davor.

    Alle Seiteninhalte, Produkte, Bilder, Bestellungen, Kunden und Kommentare, sowie Einstellungen wurden ALLE mit übernommen. Ich weiß, klingt für einen Profi absolut normal, aber für mich als Noob… ich hab mich einfach nur gefreut 😀

    Ich habe danach noch einmal Sucuri scannen lassen, jede Spur von veränderten Dateien ist weg, die Seite läuft wie am ersten Tag!

    Vielen vielen Dank für die Hilfe!!! Ich hoffe ich werde diesen Artikel nicht noch einmal brauchen 🙂

    Thread-Starter brixjust4me

    (@brixjust4me)

    Hallo und vielen Dank für die Unterstützung!

    Es lagern zum Glück keine Zahlungsdaten etc. bei uns, sondern nur Versanddaten.

    Kann ich leider nicht sagen, ich vermute dass das vor einer Weile durch ein veraltetes Plugin oder Theme kam, also irgendwo eine Stelle war, die ein Eindringen ermöglichte. Ich hatte das Problem vor ca 6 Monaten schon einmal, da konnte aber alles relativ fix mit einem Zurückrollen auf ein Backup von vor ein paar Tagen gelöst werden. Das war hier nun so nicht möglich, weil alleine die Feststellung woran es lag zu lange gedauert hat. Plugins und Themes sind alle mittlerweile Up2Date, hier eine Liste:

    • Backup-Migration
    • Cache Enabler
    • Collapse-O-Matic
    • Coupon Free Product
    • Elementor
    • Envato Elements
    • Flexible Shipping
    • Germanized
    • Hover Effects
    • Jetpack
    • Ocean EExtra
    • Ocean Stick Anything
    • Tank Math SEO
    • Real Cookie Banner (Free)
    • Tabs Responsive
    • WooCommerce
    • WooCommerce Deutsche Post Internetmarke
    • WooCommerce PDDF-Rechnungen, Lieferscheine, Lieferscheine und Versandetiketten
    • WooPayments
    • Wordfence Security
    • WP Rollback (deaktiviert)
    • WP Staging WordPress Backup Plugin
    • WP-Dateimanager
    • Theme: OceanWP

    Außer mir gibt es noch zwei weitere Admins, von mir festgelegt. Die Passwörter haben wir alle innerhalb der letzten Woche noch einmal erneuert, damit da keine Möglichkeit der Manipulation besteht. Der Rest der Benutzer sind die Kunden, diese haben keine Rechte.

    Zwischenzeitlich waren andere Admins auf der zweiten Seite angelegt (nicht von uns), diese haben wir direkt entfernt. Diese Admin-Accounts haben hauptsächlich Kommentare unter WordPress-Beiträgen freigegeben. Das übliche mit den Links zu Phishing-Websites etc. Mittlerweile ist das Problem aber behoben, keine weiteren Nutzer wurden automatisch angelegt. Die zweite Seite lag für eine lange Zeit brach, somit ist es nicht unwahrscheinlich dass der Ursprung dort liegt. Auch dort haben wir Allee Themes etc. geupdated und alle Dateien gelöscht. Hier die Liste der dort installierten Plugins und des benutzen Themes:

    • Akismet Anti-Spam: Spam Protection (deaktiviert)
    • Cache Enabler (deaktiviert)
    • Contact Form 7 (deaktiviert)
    • Elementor
    • Royal Elementar Addons (deaktiviert)
    • WP Reset
    • WP Dateimanager
    • Theme: Royal Elementar Kit

    Besteht die Möglichkeit, dass die Malware, welche sich bereits in der Seite versteckt neue Dateien selbst schreibt? Oder muss da ein Zugang von außen offen sein (Also durch Plugin etc.)?

Ansicht von 2 Antworten – 1 bis 2 (von insgesamt 2)