Verfasste Forenbeiträge

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Ich habe genau das gleiche Problem mit der gleichen Fehlermeldung seit dem Update auf 5.4.2–de_DE. Meist klappt das Update der Plugins erst nach einigen Versuchen. Besonders wenn mehrere Plugins gleichzeitig ein Update anbieten. Bei einigen klappt es auf Anhieb, bei anderen braucht es mehrere Versuche.

    Diese Fehlermeldungen waren vorher nie ein Thema bei mir.

    • Diese Antwort wurde geändert vor 3 Wochen, 5 Tage von bviadmin.
    bviadmin

    (@bviadmin)

    So, jetzt hoffentlich zum letzten Mal mit einer kleinen Hilfe für ähnlich genervte WordPresser, was die Datum- und Zeitberechnung in WordPress seit 5.3 angeht:

    Arbeitet man innerhalb WP mit Datum und Zeit (z.B. mit zusätzlichem PHP-Code in der header.php) haben die erzeugten Variablen date(), time() usw. neuerdings offenbar grundsätzlich einen UTC-Zeitstempel – EGAL, welche Zeitzone man in den Einstellungen unter „Allgemein“ man eingestellt hat.

    Bearbeitet man diesen Zeitstempel im zusätzlichen PHP-Code nicht, erhält man grundsätzlich also nicht zur eigenen Zeitzone passende Daten.

    Daher bin ich so vorgegangen:
    date_default_timezone_set(‚Europe/Berlin‘);
    – damit enthalten die Variablen die MEZ

    $datum = date(„d.m.Y“);
    $zeit = date(„H:i:s“);
    ….
    weiterer PHP-Code
    ….

    date_default_timezone_set(‚UTC‘);
    – damit WordPress intern hinterher wieder auf Basis UTC rechnet und richtige Zeitwerte in MEZ bzw. der hinterlegten Standardzeitzone anzeigt.

    Bei mir funktioniert jetzt daraufhin das Kalender-Widget wieder einwandfrei und auch meine mit dem Zusatzcode erzeugte Logdatei hat nun wieder die richtigen Datums- und Zeitwerte.

    Gruß
    Andreas

    bviadmin

    (@bviadmin)

    STOP! Kommando zurück – Da war die Seite offenbar noch im Firefox-Cache!

    Tatsächlichen Fehler gefunden:

    Ich nutze im Child-Theme in der „header.php“ für das interne Error-Reporting ganz am Anfang die Funktion

    – date_default_timezone_set(‚Europe/Berlin‘);

    Danach gehe ich wieder zurück mit

    – date_default_timezone_set(get_option( ‚timezone_string‘ ));

    damit wieder die WordPress Einstellungen übernommen werden. Das funktionierte nun jahrelang ohne Probleme.

    Offenbar bringt das die Zeitberechnungen komplett durcheinander.
    Klammere ich diese PHP-Funktion aus, funktioniert auch der Kalender korrekt. Ich werde das mal ändern und schauen, ob es weitere Auswirkungen hat.

    Gruß Andreas

    bviadmin

    (@bviadmin)

    Ergänzung:
    Sehr merkwürdig: Ich habe eine neuerliche Testinstallation gemacht. Dort war jetzt die Anzeige des Kalender-Widget richtig. Also Anzahl der Tage und Wochentagzuordnung passten. Alle Einstellungen gegenüber meiner Testseite waren identisch – außer: Die Testseite verwendet ein „Child-Theme“.

    Ich bin dann auf meiner Testseite mal auf das „Parenttheme“ (twentysixteen) gegangen. Jetzt zeigt auch hier das Kalenderwidget plötzlich richtig an. Dann bin ich wieder zurück auf mein „Childtheme“. Nun auch hier plötzlich alles richtig.

    Ich kann es mir nicht erklären, aber offenbar ist ein kurzer Wechesel auf das Parenttheme und dann wieder zurück auf das Childtheme hilfreich.

    Das werde ich weiter beobachten, ob es so bleibt.

    Gruß
    Andreas

    bviadmin

    (@bviadmin)

    Hallo!

    Das Widget zeigt seit dem Update auf 5.3 zwar den richtigen Monat als Überschrift an, aber die Anzahl der Tage (Der Dezember hat 31 und nicht 30 Tage) und die Zuordnung des Datums zum Wochentag stimmen nicht.

    Hier auf meiner Testseite (Version 5.3.1) ganz unten deutlich zu sehen. Die Testseite ist übrigens völlig plugin-frei!

    http://sb.welfenmail.de/

    Gemerkt habe ich das durch einen Leserhinweis auf meiner Produktivseite https://www.bvibs.de nach dem Update dort auf Version 5.3. Ich habe dann dort ein Rollback auf 5.2.4 (das ist bis heute so) gemacht und der Fehler war verschwunden, sprich die Wochentragszuordnung und die Anzahl der Monatstage stimmt wieder.

    Danach habe ich die o.a. Testseite erstellt, ebenfalls zunächst 5.2.4 und die Anzeige des Kalenders stimmte. Dann bin ich auch dort auf 5.3 gegangen und auch dort passte dann der Monat nicht zur Anzahl der Tage und auch die Wochentagszuordnung war falsch.

    Als Zeitzone ist seit jeher „Berlin“ eingestellt. Auch auf der Testseite.

    Ich hatte diesen Fehler schon vor einiger Zeit hier im Forum gemeldet (ein anderer Anwender hatte das gleiche Problem). Ein Bug-Ticket habe ich nicht geschrieben. Deshalb wende ich mich als Anwender ja an euch Fachleute hier im Forum, damit ihr euch der Sache annehmt… 😉

    Hier wurde das schonmal besprochen
    https://forum.wpde.org/threads/kalender-widget-zeigt-wochentage-um-einen-tag-verschoben.188146/#post-784989
    Ob das auch ein offiziellen Forum von WordPress ist, weiß ich nicht. Ich steig da nicht mehr durch….

    WP 5.3 scheint wohl diverse Probleme mit Datum und Zeit zu haben. Deshalb habe ich meine Updates auf mener Produktivseite bis auf weiteres deaktiviert bzw. gesperrt, bis alle Fehler und Ungereimtheiten beseitigt sind. WordPress traue bzw. vertraue ich derzeit überhaupt nicht mehr.

    Gruß Andreas

    Vielen Dank für die nette Antwort.

    Ich habe Jetpack installiert. Es wird mir unter „Design/Widgets“ als „Jetpack Schlagwörter-Wolke“ angeboten. Und es funktioniert eigentlich recht gut, nur ist das Ergebnis leider nicht sortierbar.

    Aber ich werde gern den Hinweis aufgreifen und das vorgeschlagene Widget ausprobieren.

    Nochmals vielen Dank für die schnelle Hilfe!

    Schönes Wochende!
    Andy

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)