Verfasste Forenbeiträge

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Thread-Starter dajanas

    (@dajanas)

    PS: Vielen Dank für den Filter, den werde ich ausprobieren 🙂

    Thread-Starter dajanas

    (@dajanas)

    @pixolin Okay, kein Problem. Es ist nun einmal so, dass der Bericht die komplette URL (und mehr) beinhaltet, die ich nicht mitteilen möchte, da ich meine Webseite schlichtweg nicht nennen möchte. Das wäre haargenau so wie wenn ich jedem hier sofort meinen Wohnort nennen würde. Es gilt Impressumspflicht. Und hier im Forum möchte ich anonym bleiben – das ist auch vollkommen in Ordnung so.

    Thread-Starter dajanas

    (@dajanas)

    @hage Haben nichts gebracht, am Theme liegt es auch nicht und es tritt ja auch erst seit ein paar Wochen auf. Ich kann nicht nachvollziehen, woran es liegt.

    Kann man diese automatischen Backups komplett deaktivieren? Ich brauche die nicht.

    Thread-Starter dajanas

    (@dajanas)

    @bscu Nein, das ist kein Widerspruch. Ich will hier im Forum die Adresse meiner Seite nicht nennen.

    Thread-Starter dajanas

    (@dajanas)

    @hage Überall, wo ich „doesnotmatter“ geschrieben habe, möchte ich Details privat halten. Das Theme, was ich nutze, ist mein eigenes Theme, das gibt es offiziell nirgendwo so. Meine Webseite ist seit vielen Jahren online, das Problem mit den Backups ist mir erst kürzlich aufgefallen – vielleicht durch irgendein WordPress-Update? Wobei ich noch nicht auf 6.0 umgestiegen bin.

    Einen anderen Browser als Chrome habe ich bislang dahingehend noch nicht ausprobiert, werde ich mal testen.

    Mit W3 Total Cache habe ich gute Erfahrungen gemacht, nutze ich seit mittlerweile fast 10 Jahren (natürlich mit Updates). Funktioniert einwandfrei.

    Den Block Editor verwende ich nicht, weil mein Backend so aufgebaut ist, wie ich es ursprünglich haben wollte (redaktionell organisiert). Mit dem Block Editor kann ich da nichts anfangen, auch weil ich manche ACF (Advanced Custom Fields) nutze, Seitenleisten usw. Den Block Editor finde ich dahingehend schrecklich 😉 Es ist nicht nur ein „einfacher“ Blog, sondern schon im Bezug auf den redaktionellen Aspekt in einem bestimmten Bereich anspruchsvoll, was die Struktur angeht und das schlussendliche Frontend. Das kann mir der Block Editor aktuell so nicht bieten, es sei denn, ich investiere Monate, um die gesamte Seite umzubauen.

    Die einzelnen Plugins hatte ich sogar so schon deaktiviert/aktiviert und es ausprobiert. Keine Änderung. Ich weiß nicht, warum „der Browser“ da Backups generiert. Von mir aus könnte man die Funktion auch vollständig deaktivieren – die „Revisionen“ habe ich schon lange per wpconfig.php abgestellt. Die automatischen Backups brauche ich auch nicht, da ich regelmäßig Beiträge speichere – wenn nicht und der PC abstürzt: Pech gehabt. Aber diese ständige Meldung bei jedem Speichern, dass die beiden Versionen sich unterscheiden, nervt sehr 🙂

    Thread-Starter dajanas

    (@dajanas)

    Hi, ja, die Seite „Website-Zustand“ kenne ich und dort ist alles in Ordnung. Nur Hinweis auf WP 6.0 und der übliche Hinweis, inaktive Plugins sollten entfernt werden, erscheint.

    
    ### wp-core ###
    
    version: 5.8.4
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: undefined
    environment_type: production
    user_count: 3 (nutze nur ich selbst)
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /is/htdocs/doesnotmatter
    wordpress_size: doesnotmatter
    uploads_path: /is/htdocs/doesnotmatter
    uploads_size: doesnotmatter
    themes_path: /is/htdocs/doesnotmatter
    themes_size: doesnotmatter
    plugins_path: /is/htdocs/doesnotmatter
    plugins_size: doesnotmatter
    database_size: doesnotmatter
    total_size: doesnotmatter
    
    ### wp-dropins (3) ###
    
    advanced-cache.php: true
    db.php: true
    object-cache.php: true
    
    ### wp-active-theme ###
    
    name: DOESNOTMATTER (doesnotmatter)
    version: 20.1
    author: DOESNOTMATTER
    author_website: doesnotmatter
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, post-thumbnails, menus, widgets, widgets-block-editor
    theme_path: /is/htdocs/doesnotmatter
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-One: version: 1.6, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (9) ###
    
    410 for WordPress: version: 0.8.7, Automatische Aktualisierungen deaktiviert
    ACF Content Analysis for Yoast SEO: version: 3.0.1, Automatische Aktualisierungen deaktiviert
    Classic Editor: version: 1.6.2, Automatische Aktualisierungen deaktiviert
    Classic Widgets: version: 0.3, Automatische Aktualisierungen deaktiviert
    jQuery Updater: version: 3.6.0.2, Automatische Aktualisierungen deaktiviert
    Ninja Forms: version: 3.6.11, Automatische Aktualisierungen deaktiviert
    W3 Total Cache: version: 2.2.1, Automatische Aktualisierungen deaktiviert
    WP Crontrol: version: 1.12.1, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 19.1, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (1) ###
    
    Contextual Related Posts: version: 3.2.3, Automatische Aktualisierungen deaktiviert
    
    ### wp-server ###
    
    server_architecture: Linux 4.14.132-xenu-he x86_64
    httpd_software: Apache
    php_version: 7.4.30-he.0 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 32M
    php_post_max_size: 32M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.38-41-log
    client_version: mysqlnd 7.4.30-he.0
    
    ### wp-constants ###
    
    WP_HOME: doesnotmatter
    WP_SITEURL: doesnotmatter
    WP_CONTENT_DIR: /is/htdocs/doesnotmatter
    WP_PLUGIN_DIR: /is/htdocs/doesnotmatter
    WP_MEMORY_LIMIT: 256M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: false
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    
    Thread-Starter dajanas

    (@dajanas)

    @bscu Ich habe es mittlerweile selbst herausgefunden. Das hat nichts mit dem Browser zu tun, es ist eine Funktion von WordPress. Man kann dies per functions.php deaktivieren.

    @pixolin Ja, diesen Code habe ich auch entdeckt und er soll überholt sein. Es gibt eine einzeilige Lösung, die auch keine Probleme mit der Canonical-Mechanik verursacht. Habe es getestet und es funktioniert, schau mal:

    add_filter( 'do_redirect_guess_404_permalink', '__return_false' );

    Damit hat sich das Problem erledigt. Wie gesagt, hat nichts mit dem Browser zu tun – dass es die automatische Ausfüllhilfe WÄHREND der Eingabe der URL in Browsern gibt, ist bekannt. Das was ich beschrieben habe, betraf aber bereits per Eingabe bestätigte URLs, die seitens WordPress automatisch erweitert werden. Das kann mit diesem Einzeiler abgestellt werden.

    Thread-Starter dajanas

    (@dajanas)

    Thanks

    Thread-Starter dajanas

    (@dajanas)

    Ah, okay, das wusste ich gar nicht. Ich habe sogar die Option deaktiviert, dass WordPress sicherheitsrelevante Updates automatisch durchführt (also für WordPress selbst). Daher wundert es mich… Ist seit über 10 Jahren somit das erste Mal bei mir passiert. Muss dann ja wohl eine gravierende Sicherheitslücke gewesen sein.

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)