Verfasste Forenbeiträge

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 61)
  • Forum: Allgemeine Fragen
    Als Antwort auf: Höhere Bildqualität

    Habe eine Zwischenfrage: „WordPress skaliert Bilder für mobile Endgeräte“ – heißt das, daß die Bilddatei kleiner wird und also die „Lademenge“ kleiner wird?

    Sooo ist das also. Ich hatte gedacht, es wäre ähnlich wie z.B. bei einem Webdesign-Programm, z.B. Dreamweaver. Man läd die Seiten, die man lokal geändert hat, hoch und fertig. Man hat alle Dateien geschützt (auch gegen Hackversuch) auf dem Rechner, falls beim upload etwas schief geht und/oder die Online-Version zerschossen ist, löscht man den Murks und läd neu hoch. Im Prinzip besser. Ist ja auch nicht unriskant, wenn von mehreren Seiten aus (Theme, plugins, WP, Seitenbetreiber…) was an der live-Version geändert wird und man dann unter Strom steht bei der eiligen Fehlersuche und Reparier-Versuchen. Aber ich will WP nauf keinen Fall schlecht machen…
    Aber ginge es nicht trotzdem so, wie ich mir das naiv vorgestellt habe? Also wäre folgender Ablauf denkbar:
    Erster Schritt: Ich poste meine news lokal (es ist keine Blogger-Seite, wo andere posten können), inklusive Mediendateien.
    Zweiter Schritt: Ich lade die dadurch geänderte Datenbank hoch (vorherige auf dem Server befindliche vorher gelöscht) sowie die Mediendateien.
    Dritter Schritt: Mit einem guten Suchen+Ersetzen-Plugin ändere ich dann die localhost-Adressen, die ja mithochgeladen wurden, in die tatsächlichen Domain-Adressen um. (Diesen Schritt könnte man eventuell auch vor dem upload auf dem localserver erledigen?)
    Fertig ist der Lack.
    Ginge das?

    Mach einen account im Forum bei slashcam.de auf, da gibts viele user die sich genau damit gut auskennen (besser als ich…).

    Also in meinem Firefox (Version 48.0.2) sehe ich das Video, in Chrome (Version 44.0.2403.157) ebenfalls.
    Komisch, in Safari (5.1.10) kommt nur der Ton, aber kein Bild.
    flv/flash ist eh fast out, verschwindet zunehmend aus der Video-Welt. Warum nimmst Du kein mp4-Format?

    • Diese Antwort wurde geändert vor 4 Jahre, 1 Monat von donaldtrump.

    Ah jetzt hab ichs! Mit shortcodes hatte ich mich bislang noch gar nicht beschäftigt, deshalb kam ich zu keinem Ergebnis. Habe jetzt erstmal Shortcodes ausprobiert – klappt; und Deine Code-Schnipsel klappen auch (wenn man im letzten noch eine abschließende Klammer = } hinzufügt, dessen Fehlen Code Snippets feststellte und eine Fehlermeldung ausgab, die ich am oberen Teil der Seite übersehen hatte – erst jetzt sah ich sie.

    Ach ja erstmal hatte bei mir die Ausgabe Deines Codes nicht geklappt, weil ich zwar eine ‚Startseite‘ habe, die aber nicht explizit als Kategorie angelegt ist…
    Vielen Dank für Deine Hilfe!

    • Diese Antwort wurde geändert vor 4 Jahre, 2 Monaten von donaldtrump.

    Änderung meines vorhergehenden Beitrages:
    Ich hatte den Code in Code Snippet nicht aktiviert((
    Nutzt aber auch nix, jetzt bekomme ich im DEBUG-Modus auf der Seite des posts die Meldung:
    ‚Notice: Trying to get property of non-object in /Applications/MAMP/htdocs/wp-content/plugins/code-snippets/php/snippet-ops.php(383) : eval()’d code on line 5‘
    In line 5 im Code Snippet-Fenster steht: $id = $idObj->term_id;

    • Diese Antwort wurde geändert vor 4 Jahre, 2 Monaten von donaldtrump.

    Ich habe gerade Deinen Code ausprobiert (nicht das plugin), und bin mit trial and error schon eine halbe Stunde zugange… aber ohne Erfolg.
    Leider bietet Code Snippet keine anständige Erläuterung, wie man vorgeht. Selbst der von Code Snippet vorgeschlagene Beispiel-Code funktioniert nicht. Man erfährt von Code Snippet auch nicht, was man im Text eingeben soll.
    Dein Code war:

    add_filter('the_content','mein_anhang');
    function mein_anhang($content){
      $idObj = get_category_by_slug('gesponsort'); 
      $id = $idObj->term_id;
      
      if( in_category( $id ) ) {
        $content .= "<p>Dieser Beitrag wurde von Firma Hubermaier gesponsert.</p>";
      }
      return $content;
    }

    Ich habe statt gesponsort Startseite eingesetzt. Im post dann [mein_anhang]. Ergebnis: nichts = [mein_anhang] erscheint bei der Ausgabe.

    • Diese Antwort wurde geändert vor 4 Jahre, 2 Monaten von donaldtrump.

    Oh danke.
    (Ich wollte es ohne weitere Info sicherheitshalber erstmal nicht ausprobieren, ich hatte die Horrorvision vor Augen daß nachträgliches Entfernen vielleicht nicht klappten könnte und ich dann einige hundert posts per Hand ändern müßte… man weiß ja nie…)

    Hallo @pixolin
    könnte man Deinen zweiten Code-snippet so modifizieren (und wie), daß man ihn an alle Beiträge nur einer definierten Kategorie anhängen kann?
    Eventuell so:

    add_filter('the_content','mein_anhang');
    function mein_anhang($content){
      if(get_post_type()=='post',category=1) {
        $content .= "<p>Dieser Absatz erscheint unter jedem Beitrag, aber nicht auf Seiten</p>";
      }
      return $content;
    }

    Und weißt Du ob bei Anlegen des Codes der entsprechende Inhalt nachträglich auf allen posts erscheint?
    … und ob man ihn auch, wenn man später den Code-Inhalt auf den posts doch wieder entfernen will, dieser komplett aus allen Beiträgen wieder gelöscht wird (bei Deaktivieren des plugins), also keinerlei Info auf den posts übrigbleibt?

    • Diese Antwort wurde geändert vor 4 Jahre, 2 Monaten von donaldtrump.
    • Diese Antwort wurde geändert vor 4 Jahre, 2 Monaten von donaldtrump.
    • Diese Antwort wurde geändert vor 4 Jahre, 2 Monaten von donaldtrump.

    @b.M.Garde
    Problem gelöst – ich hatte falsch gedacht. Ich wollte ja, wie anfangs beschrieben, einen Teil meiner posts von der Startseite wegfiltern, denen ich anfänglich auch explizit die Kategorie Startseite zugeordnet hatte. Das hatte ich dann geändert – also diese Zuordnung gelöscht. Aber -das war mir eben nicht klar- die posts erschienen trotzdem dort – weil WP das eben so handhabt.

    Dann kam mein „Nicht-Denk“-Fehler: ich habe den pre_post_Filter eingesetzt, aber als category_name die Startseite nicht geändert. Ich dachte, ok die posts sind nicht der Startseite zugeordnet, also zeigt die Startseite sie auch nicht an. Und ich wollte ja auch nur die posts dort, denen ich die Kategorie zugeordnet hatte.
    Jetzt erst habe es andersrum gemacht: im Filter die nicht erwünschten Kategorien ausgeklammert, und so erhalte ich jetzt nur die erwünschten Beiträge auf der Startseite.
    Vielen Dank für Deine Hilfe!!!!!

    Komisch ich hatte hier vorhin schon mal gepostet, war aber wohl nicht angekommen…
    Also den pre_get_posts-Filter hatte ich vorher aus der functions-Datei gelöscht.

    Vorhin hatte ich gleichzeitig hier https://wordpress.org/support/topic/how-can-i-completely-delete-custom-post-type-ui-to-make-wp-run-proper-again/#post-8178306 mein Problem gepostet und eine Antwort des plugin-Autors erhalten.

    Importieren von {“”} hat die von mir in Custom Types gespeicherten Optionen = „Test custom types“ gelöscht – prima. (Diese Möglichkeit war auf den Hilfeseiten nicht dokumentiert).

    Problem daß Beiträge ohne entsprechende Kategorie-Auswahl auf der Startseite erscheinen bleibt bestehen. Ich probiere weiter das Problem zu lösen.

    Den pre_get_posts-Filter, den ich vorher in der functions-Datei ausprobiert hatte, hatte ich wieder gelöscht. Also daran kann es (leider) nicht liegen.
    Permalinks habe ich aktualisiert. Dieses Custom Post Type funktioniert offenbar nicht korrekt, sonst würde es einmal angelegte Post Types doch einfach wieder löschen können. Und das Problem, dass nun alle Beiträge trotz anderer Katagorie-Auswahl auf der Startseite veröffentlicht werden erschien exakt nach dem Gebrauch dieses plugins. Dabei habe ich nur im dortigen basic settings einen „Post-Type-Kurzlink“ mit „Plural und Singular Beschriftung“ angelegt.
    Naja egal, ich investiere nochmal zwei Stunden und bringe WP mit dem backup und anschließend notwendigen Aktualisierungen (die noch nicht im backup erfaßt worden waren) wieder zum korrekten Funktionieren.
    Vielen Dank einstweilen für Dein Engagement!

    PS- Habe gerade vor 2 min auch hier mein Problem geschildert: https://wordpress.org/support/topic/how-can-i-completely-delete-custom-post-type-ui-to-make-wp-run-proper-again/

    Aber ich bin nicht optimistisch. Eine einfache Löschfunktion sollte ein plugin schon beherrschen… wobei auch nach einem funktionierendem Löschvorgang könnte das Problem ja weiterbestehen….

    ja danke, „probier mal“ hat funktioniert.
    Dafür habe ich jetzt einen verd…. Salat, wahrscheinlich durch Custom Post Types verursacht. Gestern hatte ich zwei „Test-post types“ angelegt, und die wieder zu löschen funktioniert einfach nicht.
    PROBLEM jetzt:
    Ich habe einen neuen Beitrag in wp geschrieben und der erscheint zwar in der ausgewählten Kategorie, aber auch zusätzlich unerwünscht auf der Startseite. Ich vermute Custom Post Types als Ursache. Habe das plugin entfernt, also deaktiviert und sogar aus dem plugin-Ordner gelöscht, aber das Problem, daß der Beitrag auch auf der Startseite erscheint bleibt. Der Grund warum ich Custom Post Types vermute ist: wenn ich nämlich die Custom Post Types neu installiere (frisch von der .zip-Datei), erscheinen die vorher angelegten Test-post-types wieder! Das plugin hat offenbar irgendwo was hingeschrieben was durch Deaktivieren des plugins nicht verschwindet (meine Laien-hafte Vermutung).

    Und, wie gesagt, das Löschen der Test-post types (entsprechend der Hilfe-Anweisungen) funktioniert nicht. Ich möchte an dieser Stelle die Qualität dieses plugins nicht kommentieren…

    Bleibt mir nur der Weg zu einem gespeicherten backup? Leider hatte ich da einige periphere Änderungen noch nicht gespeichert… die ich dann wiederholen müßte.

    jetzt pre_get_posts in die Funktions-Datei kopiert, kommt weißer Bildschirm, im DEBUG-Modus erhalte ich bei Aufruf der Homepage:
    syntax error, unexpected ‚=>‘ (T_DOUBLE_ARROW), und zwar in der Zeile $query->set( 'category_name' => 'startseite' );
    Was mach‘ ich da jetzt?

    Über Custom Post Types muß ich nach Deinen weiteren Erläuterungen noch mal meditieren, ob ich das (mit Mehrwert für meine Seite) einsetze. Was man nicht UNBEDINGT benötigt, sollte man vielleicht auch nicht einsetzen… auch unter Berücksichtigung der Performance (noch’n plugin… obwohl ich erst wenige am laufen habe)

    Habe mal testweise Post Type UI installiert – da erscheinen dann gleich mal rund 50 setting-Optionen und noch einiges andere. Englisch-sprachige Begriffe bereiten mir keine Schwierigkeiten aber herauszufinden was mit den einzelnen Optionen bezweckt wird ist offensichtlich eine Beschäftigung für lange Winterabende. Und eine rasch angelegte Testseite ist schnell angelegt, Kategorie-Auswahl nicht möglich -soll wohl automatisch auf der Startseite erscheinen (?)- aber dummerweise erscheint sie leider nirgendwo…. weiß der Geier welche Option man dazu anklicken muß…
    Ich laß mich ja gern mal auf was Neues ein aber hier habe ich Zweifel, ob das den Aufwand lohnt…
    Vielleicht habe ich es immer noch nicht verstanden? Ja es gibt ein weiteres Menü im Dashboard – da könnte ich dann -übersichtlicherweise- alle Artikel der Startseite sehen. (?) Aber die kann ich ja auch schon auf der Beitragsseite selektieren… Oder wozu ist Post Type UI gut? (Möchte nicht wissen, wieviele Hilfeseiten es für dieses plugin gibt…. damit man da durchblickt…)

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 61)