Verfasste Forenbeiträge

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 17)
  • Du hast jetzt einer nicht genutzten Konstante den Wert true gegeben – was soll das an deiner Website ändern?

    WordPress hat eine Konstante für Caching: define(‚WP_CACHE‘, true); – aber wolltest du nicht den Cache deaktivieren, damit bei Änderungen keine zwischengespeicherte Information angezeigt wird?

    true ist natürlich falsch, hatte ich hatte „DISABLE_CACHE“ gelesen. Das hatte ich bei chip.de gefunde, dass man so wohl cachen verhindern kann.

    Wie bist du denn bei der Mehrfachaktion vorgegangen?

    • 1. In der Mediathek in Listenansicht die Bilder mit Klick auf das Kontrollkästchen ausgewählt
    • 2. im Pulldown-Menü Endgültig Löschen gewählt und
    • 3. dann noch auf Übernehmen geklickt und die Aktion im anschließend erscheindenden Popup bestätigt?

    Oder nur die ersten beiden Schritte?

    1. In der Mediathek in Kachelansicht (oder wie heißt das?) auf „Mehrfachauswahl“ geklickt. Dann die Bilder ausgewählt.
    2. Ich habe dann nur die Optionen „Endgültig löschen“ und „Abbrechen“ und klicke „Endgültig löschen“.
    3. Danach erscheint ein Popup „Du bist dabei, diese Elemente endgültig von deiner Website zu löschen. Diese Aktion kann nicht rückgängig gemacht werden. Wähle „Abbrechen“ zum Stoppen oder „OK“ zum Löschen.“ und klicke auf „ok“.

    Ich habe es gerade mit der Listenansicht und den von dir beschriebenen Schritten probiert und die Bilder werden auch wirklich gelöscht und nicht mehr angezeigt. Also auch die Platzhalter verschwinden. Die muss ich jetzt nochmal alle löschen.

    Vielen Dank für die Hilfe!

    Gruß
    ebody

    Danke für den Tipp!

    Gruß
    ebody

    Ah ok, vielen Dank!

    Gruß
    ebody

    Ich habe auch das HTML Widget von Elementor verwendet und einen IFrame Code eingebaut, aber da erscheint nichts.

    Ich habe das jetzt nochmal probiert und eine andere Seite in src eingefügt und es funktioniert. Vorher hatte ich diesen Code von w3schools.com einfach testweise kopiert und eingefügt:
    <iframe src="https://www.w3schools.com"></iframe>

    aber da erscheint keine Seite. Würde mich schon interessieren warum? Aber das Problem ist gelöst.

    Gruß
    ebody

    Forum: Allgemeine Fragen
    Als Antwort auf: Unterseiten erstellen

    Vielen Dank für die Infos. Das Problem war, dass ich 2 Seiten zusätzlich zu den Hauptseiten erstellt habe. Diese habe ich aber nur gespeichert und nicht veröffentlicht. Dadurch waren die Seiten in der rechten Spalte unter „Übergeordnete Seite“ nicht vorhanden und konnte Unterseite1 nicht Unterseite2 als „Übergeordnete Seite“ zuweisen. Ich konnte beiden Seiten nur die bis dahin veröffentlichten Seiten zuweisen.

    Gruß
    ebody

    Vielen Dank! Ich habe die Checkbox im Customizer aktiviert. Damit war diese Zeile in der functions.php überflüssig:

    
    add_action( 'wp_enqueue_scripts', 'wps_deregister_styles', 100 );
    function wps_deregister_styles() {
      wp_dequeue_style( 'oceanwp-google-font-montserrat' );   
    }

    Ich musste noch diesen Code anwenden, damit auch dieser Link Metatag verschwindet, der auf eine externe Domain verweist:
    <link rel="stylesheet" id="google-fonts-1-css" href="https://fonts.googleapis.com/css?family=...>

    add_action( 'wp_print_styles', 'remove_google_fonts');
      function remove_google_fonts() {
       wp_dequeue_style( 'google-fonts-1' );   
      }

    Ich habe den Code aus dem Feld theme_mods_{theme} mit den von mir gemachten Angaben im Cusomizer kopiert, das Child-Theme aktiviert, dann in der DB Tabelle im gleichen Feld den Code eingefügt. Die Customizer Daten wurden aber nicht verwendet, es waren andere Daten. In dem Feld theme_mods_{theme} waren die richtigen Daten.

    Eine Idee, woran könnte es liegen? Ich verwende Elementor und das oceanWP Theme.

    Mit dem Plugin https://de.wordpress.org/plugins/customizer-export-import/ hat es prima funktioniert.

    Gruß
    ebody

    Eine Frage dazu habe ich noch. Kann man es verhindern, dass die Customizer Daten gelöscht/überschrieben werden, wenn man ein Child-Theme erstellt und aktiviert? Wenn ja, wie?

    Gruß
    ebody

    Vielen Dank!

    Gruß
    ebody

    Vielen Dank für die Hilfe! Ich habe die Lösung mit der .htaccess gewählt und funktioniert jetzt.

    Ich habe es jetzt so umgesetzt, dass ich per FTP kein Verzeichnis /design/ erstelle, sondern /arbeitsproben/ und darin habe ich weitere Ordner hochgeladen.

    Die vollständige .htaccess sieht jetzt so aus:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    
    # Regel für "eigenes" Verzeichnis 
    RewriteCond %{REQUEST_URI} design/arbeitsproben/.*$ 
    RewriteRule ^design/arbeitsproben/(.*)$ /arbeitsproben/$1 [L]
    
    # WordPress Regel
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Gruß
    ebody

    Hab die Lösung.

    Im Text Modus habe ich jetzt den Code so eingefügt und es funktioniert:

    <a href="#" onClick="javascript:gaOptout();">Google Analytics deaktivieren</a>

    Gruß
    ebody

    Vielen Dank für die Infos!

    Naja, du verwendest ein Multipurpose Theme, dessen verschiedene Einstellungsoptionen ja irgendwie auch abgedeckt werden sollen.

    Evtl. wird ja der Headbereich ja doch noch um einiges reduziert, wenn ich die Seite online stelle und nicht im Vorschaumodus öffne.

    Header stehen, machen durchaus Sinn und sind nicht nur aus einer Laune heraus eingefügt worden.

    Schon klar, aber es könnte ja jetzt auch so sein, dass Elementor und/oder OceanWP alle Optionen einbindet, egal ob sie genutzt werden oder nicht.

    Nur mal als extremes Beispiel was ich meine: Ich verwende jetzt nur die Elementor Widgets „Überschrift“ und „Text-Editor“ und sonst kein anderes Widget. Wenn ich die Seite veröffentliche, werden durch die Nutzung von Elementor aber CSS und JS Dateien u.a. auch für all die anderen Widgets eingebunden, obwohl sie nicht verwendet werden.

    Ob es so ist, kann ich zur Zeit nicht sagen, weil ich die Seite auch noch lokal und im Vorschau Modus betrachte. Wenn dem aber so ist, wäre die Frage, wie man so etwas verhindern kann?

    Sicher? Ich persönlich verwende RSS recht intensiv

    Mhh, meine Seite wird erstmal nur aus 4 Seiten bestehen, 2 davon sind Impressum und Datenschutz und die beiden anderen, die den Content für Nutzer enthalten. RSS Feeds machen doch eigentlich nur Sinn, wenn man regelmäßig neue Beiträge veröffentlicht oder?

    Wenn deine Website soweit steht, schau sie dir mal mit Tools wie GTMetrix oder Webpagetest.org an – da bekommst du einige nützliche Hinweise zur Performance, die du noch ausprobieren kannst.

    Noch als Ergänzung:
    https://developers.google.com/speed/pagespeed/insights/
    https://developers.google.com/web/tools/lighthouse

    Gruß
    ebody

    Danke, ich wusste nicht, dass ich das selbst machen kann. Beim nächsten mal weiß ich es 🙂

    Gruß
    ebody

    Wenn man nach Plugins in WP nach „Enlighter“ sucht und im Suchergebnis auf der Kachel auf „weitere Details“ klickt, dann auf FAQ wird die Frage beantwortet, habe ich eben gesehen:

    Can i use Enlighter togehter with Crayon ?
    No, you can’t use Enlighter together with the Crayon Syntax highlighter because it may take over the Enlighter elements.

    Gruß
    ebody

    Ok und wenn ich auf einer Beitragsseite im Backend bin, die ich bearbeite. Könnte ich da sehen, ob und welche Plugins verwendet werden? Denn auf der kaputten Seite eben, konnte ich nur raten, welche Plugins auf dieser Seite evtl. Verwendung finden.

    Auf dieser Seite wurden ja z.B. diese beiden Plugins verwendet…

    • Crayon Syntax Highlighter
    • EnlighterJS

    …welche auf anderen Beitragsseiten nicht verwendet werden.

    Das direkt sehen zu können, wäre hilfreich.

    Gruß
    ebody

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 17)