Verfasste Forenbeiträge

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 32)
  • Gut nach einem Test mit var_dump, hat sich herausgestellt, dass $max_page bei mir NULL ist. Woran kann das liegen? Die Parameter für paginate_comments_links habe ich aus dem Codex.
    Auch <?php get_comment_pages_count( $comments, $per_page, $threaded); ?> funktioniert nicht, hier ist $threaded immer NULL.

    Bin jetzt auf die folgende Zwischen-Lösung gekommen: Jedoch finde ich die etwas unsicher, da ich hier mit ceil immer aufrunde. Gibt es hier sonst keine andere Lösung?

    $comment_count = get_comments_number();
    	$max_page = ceil($comment_count/$per_page);
    	
    	$args = array(
    	'base' => add_query_arg( 'cpage', '%#%' ),
    	'format' => '',
    	'total' => $max_page,
    	'current' => $page,
    	'echo' => true,
    	'add_fragment' => '#comments'
    					
    );
    	paginate_comments_links( $args ); ?>

    Also ich habe inzwischen herausgefunden, dass wenn ich bei ‚total‘ die Anzahl der angezeigten Seiten manuell eingeben, also z.B. 5 dann funktioniert die Navigation. Allerdings werden dann natürlich immer 5 Seiten gezeigt, das will ich ja nicht. Ich möchte, dass sich die Seitenanzahl automatisch erstellt.

    Wie kriege ich das hin? Im Codex finde ich dazu nichts.

    Vielen Dank, das hat zwar bisschen gedauert aber das hat mir geholfen.

    Gibt es keine Möglichkeit Media Uploader im Widget einzustellen?

    Moderationshinweis: Bumping ist hier unerwünscht. Da wir hier alle freiwillig und unentgeltlich helfen, musst du entweder etwas Geduld mitbringen oder einen Dienstleister beauftragen. Danke für dein Verständnis. Grüße, Bego

    Funktioniert leider trotzdem nicht, da dann beide Links hauptdomain und subdomain auf die selbe Seite linken. Im WP Backend habe ich keine Möglichkeit das zu ändern. Unter Netzwerk einrichten kommt immer die Fehlermeldung von oben.

    Wir haben jetzt einfach eine zweite WP Installation in einem Unterverzeichnis erstellt. Ist zwar eine doofe Lösung aber kann man nicht ändern.

    Nach einer Neuinstallation klappt das mit der Mulitisite Installation leider nicht.
    Es kommt folgende Fehlermeldung:

    Warnung! Wildcard DNS wurde eventuell nicht korrekt konfiguriert!
    Die Subdomain-Installation versuchte, einen zufälligen Hostnamen (980e66.wordpress.p355139.webspaceconfig.de) deiner Domain zu kontaktieren. Dabei trat eine Fehlermeldung auf: cURL error 6: Couldn’t resolve host ‚980e66.wordpress.p355139.webspaceconfig.de‘
    Um eine Subdomain-Konfiguration nutzen zu können, musst du einen Wildcard DNS-Eintrag haben. Dies geschieht üblicherweise durch das Einfügen von * als Hostname-Eintrag, welcher dann auf deinen Webserver zeigt. Dies musst du im DNS-Konfigurationstool deines Servers bzw. deiner Domain tun.
    Du kannst deine Website weiterhin benutzen, nur wird jede angelegte Subdomain möglicherweise nicht erreichbar sein. Wenn du weißt, dass deine DNS-Einstellungen korrekt sind, kannst du diesen Hinweis ignorieren.

    Kann niemand was mit der Fehlermeldung anfangen:

    Warnung: Ein bestehendes WordPress-Netzwerk wurde gefunden.

    Muss ich für diese Installation noch was beim phpMyAdmin einstellen?

    Grüße

    • Diese Antwort wurde geändert vor 3 Jahre, 2 Monate von juicylung.

    Super Danke, genau das was ich gesucht habe.

    Grüße

    Hey Soeren,

    danke für die zahlreichen Empfehlungen. Das Buch von David Remer hat mich auf Anhieb angesprochen und ich habs mir sofort bestellt. Halte es gerade in den Händen und muss sagen, bisher bin ich sehr überzeugt.

    Danke dir! Die anderen Bücher behalte ich mal im Hinterkopf bis ich das erstmal durch habe. Ist jedenfalls das was ich gesucht habe.

    Grüße

    Hey Torsten nicht falsch verstehen, ich will was lernen und nicht eine vorgeschriebene Lösung bekommen ;), also musst du deine Zeit dafür nicht opfern. Der Tipp mit den Plugins ist für mich schonmal ein Schritt weiter, ich werde mal gucken ob ich da durchblicken kann.
    Für mich als Anfänger ( erst Mitte Dezember mit PHP und WP angefangen) ist es schonmal eine Hilfe zu wissen, dass das überhaupt möglich ist.

    Danke vorerst 😉

    Gibt es hier keine einfache Möglichkeit?

    Hat jemand eine Hinweis wie ich mich an die Lösung machen könnte?

    Leider kann ich nichts mehr am ersten Beitrag ändern, deswegen hier ein zweiter Post.
    Zum Verständnis. Das Inputfeld habe ich absichtlich soweit abgespeckt, damit man sieht was ich meine.
    In WP selbst rufe ich natürlich mit get_post_meta die jeweilige ID und die Variable auf:

    echo '<input name="Menge[]" class="form-control" value="'.esc_html(get_post_meta($post->ID, 'Menge[]'. false )).'"></td>';

    Lässt sich das vielleicht einfach nicht lösen, weil die Felder mit JavaScript generiert werden? Wie könnte ich das alternativ lösen?

    • Diese Antwort wurde geändert vor 3 Jahre, 3 Monate von juicylung.

    Ohh je! Torsten du bist mein absoluter Held. Das sind so Kleinigkeiten die man als Anfänger noch nicht sieht.

    Vielen Dank!

    Danke, es gibt also keine Methode die Standard ist? Welche nutzt du?

    Und wie sieht es mit der Möglichkeit Layouteigenschaften im Backend zu ändern?

    Grüße

    Danke nochmal für die Hilfe, kann dann jetzt als GELÖST markiert werden.

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 32)