Verfasste Forenbeiträge

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Thread-Starter maurerib

    (@maurerib)

    Hallo @hage , prinzipiell eine gute Idee mit der lokalen Installation. Nur weiß ich eben nicht, wo ich anfangen soll zu suchen 🙂

    Danke für Deine Mühe!

    Thread-Starter maurerib

    (@maurerib)

    Hallo @hage ja, bereits mehrfach. Leider ohne Erfolg.
    Im Adminmenu fehlt mir auch der Menupunkt „Dashboard“ .. irgendwo muss es eine Datei zerschossen haben – nur leider weiß ich nicht, welche Dateien ich manuell aktualisieren kann.

    Thread-Starter maurerib

    (@maurerib)

    Hallo @pixolin ,

    die Fehlermeldung kommt beim Login (gehe dann zwei Seiten zurück und habe die Adminleiste im Browser), wenn ich das Update starten möchte.
    Zudem kann ich keine neuen Seiten anlegen, die Seite ist dann einfach weiß.

    Ja, ich bin Administrator – habe das auch über phpMyAdmin nachgeschaut und eingestellt.

    Die Webseite habe ich installiert. Ist auch nicht die erste WordPress Installation, die ich durchgeführt habe.

    Thread-Starter maurerib

    (@maurerib)

    Habe nun wp-admin, wp-includes und sämtliche Dateien aus dem Hauptverzeichnis aktualisiert, trotzdem bekomme ich die Fehlermeldung

    Du bist leider nicht berechtigt, auf diese Seite zuzugreifen

    wenn ich mein einloggen möchte.

    Habe sogar bereits in der Datenbank div. Anpassungen gemacht.

    Thread-Starter maurerib

    (@maurerib)

    @espiat Danke! Schaue ich mir an.

    @pixolin
    Nein, das war keine 1-Click.

    <?php
    /**
     * Grundeinstellungen für WordPress
     *
     * Zu diesen Einstellungen gehören:
     *
     * * MySQL-Zugangsdaten,
     * * Tabellenpräfix,
     * * Sicherheitsschlüssel
     * * und ABSPATH.
     *
     * Mehr Informationen zur wp-config.php gibt es auf der
     * {@link https://codex.wordpress.org/Editing_wp-config.php wp-config.php editieren}
     * Seite im Codex. Die Zugangsdaten für die MySQL-Datenbank
     * bekommst du von deinem Webhoster.
     *
     * Diese Datei wird zur Erstellung der wp-config.php verwendet.
     * Du musst aber dafür nicht das Installationsskript verwenden.
     * Stattdessen kannst du auch diese Datei als wp-config.php mit
     * deinen Zugangsdaten für die Datenbank abspeichern.
     *
     * @package WordPress
     */
    
    // ** MySQL-Einstellungen ** //
    /**   Diese Zugangsdaten bekommst du von deinem Webhoster. **/
    
    /**
     * Ersetze datenbankname_hier_einfuegen
     * mit dem Namen der Datenbank, die du verwenden möchtest.
     */
    define( 'DB_NAME', '***' );
    
    /**
     * Ersetze benutzername_hier_einfuegen
     * mit deinem MySQL-Datenbank-Benutzernamen.
     */
    define( 'DB_USER', '***' );
    
    /**
     * Ersetze passwort_hier_einfuegen mit deinem MySQL-Passwort.
     */
    define( 'DB_PASSWORD', '***' );
    
    /**
     * Ersetze localhost mit der MySQL-Serveradresse.
     */
    define( 'DB_HOST', 'localhost' );
    
    /**
     * Der Datenbankzeichensatz, der beim Erstellen der
     * Datenbanktabellen verwendet werden soll
     */
    define( 'DB_CHARSET', 'utf8mb4' );
    
    /**
     * Der Collate-Type sollte nicht geändert werden.
     */
    define('DB_COLLATE', '');
    
    /**#@+
     * Sicherheitsschlüssel
     *
     * Ändere jeden untenstehenden Platzhaltertext in eine beliebige,
     * möglichst einmalig genutzte Zeichenkette.
     * Auf der Seite {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * kannst du dir alle Schlüssel generieren lassen.
     * Du kannst die Schlüssel jederzeit wieder ändern, alle angemeldeten
     * Benutzer müssen sich danach erneut anmelden.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         '***');
    define('SECURE_AUTH_KEY',  '***');
    define('LOGGED_IN_KEY',    '***');
    define('NONCE_KEY',        '***');
    define('AUTH_SALT',        '***');
    define('SECURE_AUTH_SALT', '***');
    define('LOGGED_IN_SALT',   '***');
    define('NONCE_SALT',       '***');
    
    /**#@-*/
    
    /**
     * WordPress Datenbanktabellen-Präfix
     *
     * Wenn du verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank
     * verschiedene WordPress-Installationen betreiben.
     * Bitte verwende nur Zahlen, Buchstaben und Unterstriche!
     */
    $table_prefix = 'wp_';
    
    /**
     * Für Entwickler: Der WordPress-Debug-Modus.
     *
     * Setze den Wert auf „true“, um bei der Entwicklung Warnungen und Fehler-Meldungen angezeigt zu bekommen.
     * Plugin- und Theme-Entwicklern wird nachdrücklich empfohlen, WP_DEBUG
     * in ihrer Entwicklungsumgebung zu verwenden.
     *
     * Besuche den Codex, um mehr Informationen über andere Konstanten zu finden,
     * die zum Debuggen genutzt werden können.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    define( 'WP_DEBUG', false);
    
    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß. */
    /* That's all, stop editing! Happy publishing. */
    
    /** Der absolute Pfad zum WordPress-Verzeichnis. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', dirname( __FILE__ ) . '/' );
    }
    
    /** Definiert WordPress-Variablen und fügt Dateien ein.  */
    require_once( ABSPATH . 'wp-settings.php' );
    
    Thread-Starter maurerib

    (@maurerib)

    Hallo Bego,

    besten Dank für den Tip.
    Habe ich alles genauso ausgeführt – leider ohne Erfolg.

    Ich denke, ich komme nicht drum herum WP komplett neu zu installieren.

    Viele Grüße
    Stefan

    Thread-Starter maurerib

    (@maurerib)

    Hallo zusammen,

    kann man denn das WP Update rückgängig machen?
    Ich habe das Gefühl, dass die Probleme erst seitdem aufgetreten sind.

    Viele Grüße
    Stefan

    Thread-Starter maurerib

    (@maurerib)

    Hallo,

    ja genau. Sobald ich auf „Problembehandlungmodus aktivieren“ klicke, fliege ich raus.

    Grüße
    Stefan

    edit
    Mir ist gerade auch noch aufgefallen, dass einige Links im Control Panel nicht mehr verfügbar sind:
    – Menupunkt „Dashboard“ fehlt
    – „Profil bearbeiten“ fehlt
    – Mein Anmeldename ist kein Link mehr, sondern nur noch Text
    – Beim Mouseover des WP-Logos fehlt „Über WordPress“

    • Diese Antwort wurde geändert vor 4 Jahren, 1 Monat von maurerib.
    Thread-Starter maurerib

    (@maurerib)

    Hallo,

    in der Menuleiste im Control Panel fehlt der Menupunkt „Dashboard“.. Ich meine mich zu erinnern, dass es einen solchen gibt ?!

    Wenn ich, nachdem ich alle Plugins (bis auf Health Care) deaktiviert habe, die Problembehandlung starte, fliege ich gleich aus dem Control Panel raus mit der Meldung „Du bist leider nicht berechtigt, auf diese Seite zuzugreifen.“

    Grüße
    Stefan

    Thread-Starter maurerib

    (@maurerib)

    Hallo Hans-Gerd,

    besten Dank für den Tip!
    Habe das Plugin installiert.. Würde den Health Check gerne durchführen, allerdings wird der Menupunkt „Dachboard“ nicht angezeigt.

    Ich glaube, wir kommen dem Problem langsam auf den Grund.. 😉

    Viele Grüße
    Stefan

    btw. leider kann ich den EIngangspost nicht mehr ändern.
    Webseite http://www.maurer-ib.de

    • Diese Antwort wurde geändert vor 4 Jahren, 1 Monat von maurerib.
    Thread-Starter maurerib

    (@maurerib)

    Hallo,

    ein paar weitere Einschränkungen:

    – Ich kann keine neuen Beiträge und Seiten erstellen, die Seite lädt und bleibt weiß.
    – Ich kann meinen Benutzer nicht bearbeiten: „Du bist leider nicht berechtigt, auf diese Seite zuzugreifen.“

    Grüße
    Stefan

    Thread-Starter maurerib

    (@maurerib)

    Hallo Hans-Gerd,

    danke für Deinen Tip.
    Ich habe die Datei mit Weaverslave bearbeitet.. Seit Jahren gibt es keine Probleme.

    Meine Vermutung ist, dass es weniger mit der Konfiguration zu tun hat, als mehr mit vielleicht einem falschen Datenbankeintrag o.Ä.
    Irgendetwas wird beim Login ausgelöst, dass anstatt aufs Dashboard weiterzuleiten, die Fehlermeldung angezeigt wird.

    Viele Grüße
    Stefan

    Thread-Starter maurerib

    (@maurerib)

    So, ich muss mich leider korrigieren.. Oben Geschriebenes scheint leider nicht zum „Erfolg“ zu führen. Über Tips bin ich sehr dankbar!

    Grüße
    Stefan

    Thread-Starter maurerib

    (@maurerib)

    .. auf wundersame Weise funktioniert es nun wieder, nachdem ich in der wp-config den debug erst auf true und dann auf false gesetzt hatte.. Ob es da einen direkten Zusammenhang gibt, weiß ich nicht ..

    Grüße
    Stefan

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)