Verfasste Forenbeiträge

Ansicht von 15 Antworten - 226 bis 240 (von insgesamt 252)
  • Hallo

    ich hätte sowas in der Art auch gesucht, aber nichts gefunden. „In der Art“, weil ich nicht genau weiß was du vorhast, und weil das Thema für mich neu ist.

    Bin aber auf „Steady“ gestoßen, da gibts auch so Mitgliedsschaften, Abos und Pakete, womit man nebst Inhalten alles mögliche verkaufen kann. Leider ist deren Paywall kinderleicht zu knacken, also nichts für Bezahlschranken (was ich suche).

    Ein anderer Dienst namens „LaterPay“ ist da schon sicherer, aber alles englisch. Versuche es dennoch zu kapieren, wie der Laden läuft.

    Dann gäbs da noch „Plengio„, die kenne ich aber noch gar nicht.

    PS: Goggle mal: „Automattic kauft eine Publishing-Plattform“ – evtl. auch mal interessant.

    PS an Mods: Besch… ist das hier, für Links banned zu werden.
    Oder habe ich eh schon wieder gegen ungeschriebene uo. bestens versteckte Regeln verstoßen mit der Nennung der Anbieter? (Wenn ja, sags mir gleich)

    kann mich nicht mehr im Backend einloggen

    Live-Quellseite oder Zielseite am MAMP? Letzteres oder?

    Installer.php habe ich ausgeführt – …nicht berechtigt, auf diese Seite zuzugreifen

    Nun, dann kann ja noch lange keine Rede von „nicht ins Backend einloggen“ sein.
    Wenn es (vmtl.) schon beim anklicken der Installer.php, also ersten Schritt der Installation des Klons scheitert, gibts ja noch kein Backend.

    Wie schaut denn deine lokale Datenbank aus? Hast die vorher eh ausgeräumt? Oder ist da noch was vom vorigen, manuellen Versuch, von den Anpassungen drinnen? Besser alle Tabellen löschen.

    Irgendwelcher Schreibschutz wird ja nicht wirklich irgendwo drauf sein? Kommt unter Win schon mal vor, dass ausgerechnet irgendeine wichtige Datei sich „von selbst“ schreibgeschützt hat und man sucht stundenlang Scriptfehler. Bei MAC kenn ich mich halt nicht aus.

    Ansonsten weiß ich auch nicht, tut mir leid. Hoffe die Profis melden sich bald.

    PS: Es gäbe da noch ein Plugin, dass ich früher verwendete: „MigrateDB“. Kann in der Gratisversion die DB sichern und ggf. auch das Suchen und Ersetzen recht einfach machen.
    Da habe ich früher alle Dateien einfach per FTP runtergeladen und die per MigrateDB gesicherte und auf den localhost umgebogene DB angeschlossen, Fertig.
    Dazu gäbe es hier ein paar gute Tipps: Google nach MigrateDB site:journalismus-plus.de

    MAMP – wg. MAC, aha. Unter Wind hieß es mal WAMP, va. in den Prä-XAMPP Zeiten als man sich all die Komponenten noch selber zusammengestoppelt hat.

    Sorry, bin dann weg, die Grießnockeraffäre kommt auf BR – Servus!

    Hallo!

    Bin zwar keiner der Profis hier, habe aber ein tolles Plugin entdeckt, welches die Migration von einem Server zum anderen fast automatisch kann.
    Natürlich auch von einer Live Site zu einem Server am lokalen Testrechner, zB. auf XAMPP.

    Das Plugin heißt „Duplicator“ (Sorry, Links darf ich hier nicht rein tun, sonst sperren die mich wieder) Ist aber im offiziellen WP Plugin-Verzeichnis zu finden.

    PS: Was ist MAMP?

    • Diese Antwort wurde geändert vor 1 Jahr, 6 Monaten von pezi.
    Forum: Allgemeine Fragen
    Als Antwort auf: Werbung einbinden

    Hallo

    Ich weiß nicht ob mein Theme Werbung unterstützt

    Das zeigt sich ua. in den Einstellungen zum Theme, per Customizer oä.
    Wenn da irgendwo was von „Banner“, „Werbung“, „Advertisement“, oä. steht, dann hat das Theme vordefinierte Plätze für sowas.

    Leider darf ich hier keine Links setzen, sonst könnte ich zb. zu MH Magazine Theme verlinken. Da sieht man auch gleich am Screenshot des Themes, das zb. im Header ein Banner-Platz vorgesehen ist.

    Bei diesen Themes erspart man sich also das Basteln eines solchen Bereiches, oder das manuelle hinzufügen (per Widgets, Shortcodes, usw.) etwa in eine Sidebar oä.

    In Verbindung mit dem oben genannten Banner-Plugin fürs Management der Werbung ist das echt eine leistungsfähige Sache.

    PS: „pezi2“ ist/war ein neues Profil von „pezi“. Weil Profil „pezi“ wg. Links abgemahnt wurde. Mittlerweile gehts aber wieder (Danke Torsten!) und so bin ich wieder der „alte ‚pezi'“ hier.

    Hallo!

    Das zweite Profil kann man eh löschen, falls ich mit dem „alten“ wieder wie immer sofort posten darf. Der Grund fürs 2.te Profil steht ua. in den Mails.

    Kontext

    Ich glaube nicht, dass ich hier „Werbung“ für jemanden machte. Schon gar nicht für die eigenen Sites!

    Grade im neuen Profil antwortete ich jemanden, der wg. „Werbung einbinden“ wg. Banner Plugins fragte und ich bestätigte deine (verlinkte) Meinung über einen bekannten dt. Anbieter eines solchen Plugins.

    Hätte ICH den Link zu dem Autor eingetippt, wäre ich schon gelöscht …

    Was ist denn nun Werbung, was ist Hilfe?
    Wo war denn nun mein „Vergehen“?
    Wie soll man sich da verhalten, hat das überhaupt Sinn, bei jedem Link zu grübeln „darf man oder dürfen das nur die anderen?“ …

    Nachtrag zum letzten Mail:

    Diese Guidlines u. das mit „Slack“ habe ich noch nie gesehen und wenn, was macht man in u. auf internationalen Foren und Sites, wenn man kein Englisch kann?
    Bitte nicht die Standard-AW „dann such dir ein anderes Hobby als Websites basteln, betreiben usw.

    • Diese Antwort wurde geändert vor 1 Jahr, 6 Monaten von pezi. Grund: Nachtrag zum Mail

    Hallo und danke für die PM und die Freischaltung.
    Habe das Thema aber mittlerweile mit einem neuen Profil gepostet. Sorry.

    PS: Evtl. könnte man das gleich mitteilen, wenn jemand gegen etwas verstößt?
    Oder irgendwo vermerken, dass nicht jeder Links verwenden darf – in den FAQ fand ich dazu nichts.
    Dh. das auch mein neues Profil bald wieder „markiert“ wird? Habe ja auch da Links benutzt – wie soll man den ohne auf irgendwelche Sites, Tools oä. verweisen?

    Das mit den Freiwilligen weiß ich und Danke für eure Arbeit. Ich verlangte aber auch keine Support-Leistung oä., sondern der Kern der Fragen war, ob das schon mal jemand erlebt hat, uo. eine Idee hat.

    Und die Nachfragen sind nur weil ich nicht wusste, warum meine Beiträge nicht erscheinen – nicht warum so lang keine Antworten eintrudeln, oä. unsinnige Urgenz.

    Bitte nur noch mir zu sagen, wie man hier ohne Links zu externen Quellen verweisen soll?

    Danke!

    Hallo!

    Naja, du hast zu viele Kategorien – und ich gar keine mehr (*) …
    Leider weiß ich auch nicht wo deine beiden Kategorien her kommen. Hätte auch auf ein Plugin getippt.

    Theme Fortuna: ist es das hier?
    Weil das wäre lt. Hersteller? noch nicht WP 5.x kompatibel.
    Doch ob das mit den seltsamen Kategorien zusammenhängt?

    *) Warum antworte ich dir hier, wenn ich eh nicht helfen kann?
    Naja, weil wie gesagt, bei mir (noch WP 4.9.9) sind alle 23 Kategorien aus dem Backend verschwunden und noch eine Menge unglaublicher Fehler passiert …
    Aber: Meine Beiträge werden seit ca 20 h nicht freigeschaltet …

    Evtl. kann mir jemand sagen, wie lange eine Beitragsprüfung dauert … Es wäre echt dringend …

    Danke!

    Forum: Plugins
    Als Antwort auf: Regenerate Thumbnails weg

    Hallo und Danke

    Ich kapiere diese Grafik zwar nicht ganz (wie auch? Bin kein Programmierer oder so); Aber dh. was im innersten Kasten ist, kommt rel. spät, eher zum Schluss dran.
    Dh. auch, dieses plugins_loaded wäre nur ein Schritt vor der functions.php des Childs.
    Wenn also jemand plugins_loaded als „Start“ für sein Plugin-Script nimmt, kommen Codes aus der functions.php quasi zu spät. Zu spät um das zuvor gestartete Script zu beeinflussen?

    Bei init stehen die Befehle aus der functions.php schon im Quelltext, wenn das Pluginscript startet.

    Etwas OT:
    Die functions.php des Childs wird vor der des Eltern Themes geladen? Nehme an, dass ist weil man in der Datei ja gewisse Funktionen des Parent nochmal notieren (u. modifizeren) kann. Und die functions.php des Parent-Themes hat ein if () davor.
    if (!function_exists('funktionsname')) {
    Wenn nicht, startet die vom Parent, wenn vorhanden, dann die vom Child – stimmts?
    (Den Absatz kann man löschen wenns nicht hier her passt – wäre nur zum Verständnis dieser Lade-Hierarchie)

    Danke!

    Forum: Plugins
    Als Antwort auf: Regenerate Thumbnails weg

    Echt? Cool!

    Tja, dann Danke nochmals – auch an den Plugin-Autor. Dem ich bloß ein Thanks you schrieb …

    Tschü

    Forum: Plugins
    Als Antwort auf: Regenerate Thumbnails weg

    Ja, evtl. kapiere ich es nun teilweise.

    in der alten Version stand am Ende der regenerate-thumbnails.php:

    // Start up this plugin
    add_action( 'init', 'RegenerateThumbnails' );
    function RegenerateThumbnails() {
    	global $RegenerateThumbnails;
    	$RegenerateThumbnails = new RegenerateThumbnails();
    }

    Da wird die darunter notierte function RegenerateThumbnails() per init aufgerufen, gestartet oder so. Und diese „init“ Methode lässt zu, dass eigene Theme-Funktionen vorher laufen können.

    Nun stand ab v 3 da:
    add_action( 'plugins_loaded', 'RegenerateThumbnails' );
    Das plugins_loaded scheint, hmmm … anders zu sein, es lädt das Plugin schneller, immer vor dem Theme, dessen functions.php.

    Damit haben wir die „alte“ Initialisierung wieder hergestellt:
    add_action( 'init', 'RegenerateThumbnails' );

    Ich bemühe mich es zu verstehen, aber ich bin nur ein interessierter Laie. Evtl. ist meine obige „Erklärung“ völliger Blödsinn.
    Im Endeffekt reichts wenn alle Autoren das RT wieder sehen.

    Jedenfalls Danke für alles – allein hätte ich das nie hinbekommen!

    Forum: Plugins
    Als Antwort auf: Regenerate Thumbnails weg

    Hallo und Danke!

    Das funzt.

    Die Antwort vom Autor hätte ich ohnehin nicht verstanden, aber evtl. kann man mir das irgendwann mal erklären, warum es nun geht und wie das mit dem Snippet zusammenhängt, usw. …

    Ich kapiere nur, dass nun wieder das bisherige „init“ verwendet wird, dann gehts. Im codex stünde es eh, was das alles heißt, wo der Unterschied zu „plugins_loaded“ ist – aber wie gesagt, ich verstehe es nicht.

    Nochmal Danke!

    Forum: Plugins
    Als Antwort auf: Regenerate Thumbnails weg

    Hallo Bego
    Zum 1. Absatz: Ja, weiß ich. Sagte ich ja, dass ich dies deswegen in die functions.php des Child-Themes gab. Wo ich es vor Updates des Plugins sicher wähnte.

    zum 2. Absatz: Den Tipp mit manage_options gab mir jemand aus einem Forum, das klappte auch – bis eben die neue regenerate_thumbnails.php kam. Eh klar.
    upload_files – hab ich mir selber ausgesucht, dachte wer Bilder raufladen darf, wird die auch verändern wollen, dürfen. Klappte auch.
    Beide Sachen sollten eben nur sicherstellen, dass meine Autoren dass auch weiterhin können.
    (Nirgends glaubte ich, dass würde vor Update bedingten Änderungen schützen)

    Sorry, dass habe mit dem engl. Supportforum habe ich knapp nach dem Eintrag hier gemacht und den kann man ja nicht editieren. Danke für die Mühe – aber Antwort hat noch keiner unserer Beiträge. Denke es gibt noch mehr Probleme mit RT, seit v 3.0?

    Wieso ich, (bzw. die Autoren) RT brauche:
    Nun, ich weiß, es ist nach einem Themewechsel super zur Neuberechnung der Bildgrößen, dafür war es ursprünglich ja installiert.
    Doch es gibt ein weiteres Einsatzgebiet, welches hpts. die Autoren betrifft:
    Wir haben ua. ext. Bildquellen, zT. von pixabay und die Autoren holen mit deren Plugin Bilder rein. Jene gehen aber nicht durch den WP, bzw. Theme-gesteuerten Image-Prozess (oder wie das heißt) sondern werde nnur in einer Größe geladen.
    Um jene auch in die div. Bildgrößen des Themes zu bringen ist RT täglich viele Male im Einsatz.

    Nun könnte ich meiner Chefin und Redakteurin auch den Admin geben, dann gehts wieder. Aber die meckert dann wegen all der „unnötigen Sachen“ Menüeinträge mit denen sie besser eh nichts anfängt.

    Nochmal Danke für deine Mühe

    Forum: Plugins
    Als Antwort auf: Regenerate Thumbnails weg

    Hallo und Danke für die Antworten

    das Snippet funktioniert auch, wenn du es an die regenerate_thumbnails.php anhängst, aber nicht mehr im Theme.

    Sowas ähnliches hab ich früher mal gemacht und beim Update wars natürlich weg.
    Da riet mir jemand folgendes zu machen:
    statt manage_options
    $this->capability = apply_filters( 'regenerate_thumbs_cap', 'manage_options' );
    „upload_files“ notieren
    $this->capability = apply_filters( 'regenerate_thumbs_cap', 'upload_files' );

    Daher hab ich mir dann die (eingangs erwähnte) Lösung mit dem Filter, aber id. functions des Child ausgedacht, denn das sollte vom Update des Plugins nicht berührt werden. So mein laienhaftes Denken.

    Ich verstehe eure Kritik, wenn ich immer lese „Frag den Entwickler … des Plugins, Themes, … etc.“ Das würde ich gerne tun, doch ich kann kein englisch, daher sind auch alle Tipps zu fremdsprachigen Ressourcen gut gemeint, aber für mich leider selten nützlich.
    Auch kenne ich mich (daher) nicht mit so Sachen wie Bugmeldern uä. aus, lasse diese Optionen lieber jenen, die sich auskennen.

    PS: Habe die Sache aber per Google-Translator ins Supportforum gestellt. Da antwortete mir zwar noch keiner, dafür bekomme ich einen Haufen Mails von denen – die ev. auch damit zu tun haben?

    Danke!

    Danke, aber leider schaff ichs nicht damit. ist sicher einfach, aber ohne Englischkenntnisse ist die Anleitung schwierig.

    Hab vieles versucht, aber die Seite bleibt leer, keine Fehlermeldung. Obwohl ich eh einige Debugging Sachen in der wp-cpnfig eingeschaltet habe. Auch im LOG tut sich nicht viel, nur nicht existente Tabellennamen weren angemeckert (klar, die Beispiele kommen ohne mein präfix, wenn man das vergisst…)

    WordPress-Datenbank-Fehler Table ‚meinedbname.wp_options‘ doesn’t exist für Abfrage SELECT * FR ist eine Fehler weil meine Tabellen das präfix „kas_“ davor haben.

    Aber sicher vergesse ich irgendwas um dieses WP DB Objekt richtig herein zu holen oder was weiß ich.

    So geschafft!

    ich hab testweise eine manuelle Verbindung zur DB gebaut (weil ich mit den (zweifellos bequemeren) eingebauten WP Funktionen nicht auskenne)
    aber das funzt genau wie gewünscht
    Es gibt mir eine Tabelle aus welche pro Zeile ein Bild beschreibt, mit eben der Bild-Unterschrift usw. und auch den Link der in ‚guid‘ sitzt war nützlich.

    $obj_mysqli = new mysqli($dbserver, $dblogin, $dbpassword, $dbname);
    if ($obj_mysqli->connect_errno) {
    printf("Verbindungsfehler: %s\n", $obj_mysqli->connect_error);
    exit();
    }
    
    $sql = "SELECT ID, post_content, post_title, post_status, post_excerpt, post_name, post_parent, guid, post_type FROM wp_posts WHERE post_status='inherit' AND post_type='attachment' AND post_excerpt!='' ORDER BY wp_posts.ID DESC";
    
    $result=$obj_mysqli->query($sql);
    
    echo "<table border=1>";
    echo "<tr> <th><b>Bild-Unterschrift mit © Info u. Quellen</b>:</th> <th style='width:25%'>Bild-Titel: </th> <th style='width:25%'>Bild-Beschreibung: </th> <th style='width:5%'>Link</th> </tr>";
    while ($row = $result->fetch_row()) {
    echo "<tr> <td> ".utf8_encode($row[4])."</td><td>".utf8_encode($row[2])."</td><td>".utf8_encode($row[1])."</td><td>Bild</td> </tr>\n";
    }
    echo "</table>";
    $result -> close();

    PS: das ganze noch stylen und die UT8 Sache sollte ja schon in der SQL Abfrage gehen „CONVERT(post_excerpt USING utf8)“ klappte leider nicht. Aber das wird schon

Ansicht von 15 Antworten - 226 bis 240 (von insgesamt 252)