Verfasste Forenbeiträge

Ansicht von 15 Antworten - 31 bis 45 (von insgesamt 314)
  • Achso, die quadratischen Bilder meinst.

    Tja, irgendwie muss das Theme (uo. das Widget) aus rechteckigen Bildern quadratische machen, wenn diese so gewollt sind. Schaut ja auch gut aus.
    Nur irgendwas fehlt dann, das Script (oder eine Einstellung im Widget, …?) entscheidet, was fehlt. Evtl. kann man diese Bilder auch ohne Beschneidung einstellen, aber dann sind sie nicht mehr quadratisch, sondern so breit wie das Quadrat, dafür nur so hoch wie es das Format zulässt.

    Evtl. solltest für diese 4 schon quadratische Bilder erstellen.

    Das weiß ich eben nicht, daher die Frage, wo man die angeblichen Einträge in echt findet?

    So schaut zB. das Dasboard aus:

    Und klickt man drauf, kommt:

    Nachtrag: Es passiert nur bei Sites, welche echt keinen Fehler im „Website Zustand“ zeigen. Sobald echt eine Beanstandung ist (zb. Kein HTTPS), dann ist die Einträge Anzahl im Dashboard richtig.

    Also coole, schnelle Site, und die Bilder scheinen mir ok.
    Die Originalbilder sind gleich wie die dargestellten Instanzen. Nur halt kleiner, aber nirgends fand ich eins, das echt abgeschnitten wäre.

    Die Hinweise sind ja ok – doch da sie falsch sind, verwirrt das die Leute.
    Daher die Frage: Wie kriegt man diese falschen Fehlermeldungen weg?

    Die Sites sind tatsächlich am neuesten Stand, PHP 7.4 läuft, es wird im „Website Zustand“ von 0 Problemen berichtet. Doch im Dashboard steht was ganz anderes.
    Entweder gibt es tatsächlich Probleme, welche sich nur bei noch detaillierter Analyse zeigen (wie, wo?)
    Oder ist es echt ein Fehler bei neueren WP Version?

    @pixolin:
    1.) Ich bedanke mich eigentlich fast in jedem Beitrag für Deine und die Hilfe anderer hier.

    2.) Vielen Danke für diese Erklärung. Ich habe sie leider nicht kapiert, was an mir liegt.

    3.) Ich wollte das Thema „Übersetzung“ auch nicht vertiefen, sondern ggf. mal einen eigenen Beitrag/Frage zT. zu eröffnen.
    Ansonsten dachte ich, kommt der Hinweis, eben das nicht in einem Thread zu vermischen.

    4.) Nochmals auch Danke fürs Helfen bez. der eigentlichen Problemstellung! Das war mir wichtig, das konnten wir lösen. Und ich glaube ich habe mir die Lösung nicht zu 100% vorarbeiten lassen, sondern ganz brav meine eigenen Gedanken dazu umgesetzt.

    5.) Ich hab hier auch schon geholfen, meist öffentlich lesbar. Habe auch schon haarsträubende oder gar keine Antworten bekommen. Aber auch mal Dankesworte.
    Tut mir leid, wenn meine vorige Antwort so kurz und undankbar erschien. So war es nicht gemeint!

    @pixolin – es hat da wieder einer gefragt, deswegen mal eine ausführlicher Antwort, warum keine Links.

    Klar kenne ich die FAQ und den Sinn bez. Link.

    @pixolin: Wenn keine Probleme sind? (deswegen „false positive“)

    Mit den Kunden drüber reden mach ich eh. Doch deren Merkfähigkeit in so Sachen liegt max. bei einer Woche. Dann ist wieder das Internet gelöscht, ohne es vorher ausgedruckt zu haben!

    Remove: Naja, da ist das ausblenden einfacher. Nur manche spielen herum und zeigen es wieder an. Werde also bei einigen die dauerhafte Lösung erwägen – Danke

    @bscu: Was meinst mit „andere Meldungen“? Es ist nur genau diese eine Meldung, welche von 5 Einträgen spricht.

    IdF. sind es 3 neue Sites, welche noch am XAMPP sind.

    Und ja, ich habe Kunden, die ihre Site nirgends „zur öffentlichen Begutachtung“ stellen wollen. Warum? Keine Ahnung. Ok, in 2 Fällen schon, zB. private Sammlungen extrem wertvoller Sachen. Die sollen nur ausgewählte Leute sehen, daher sind die Sites auch hinter einer Zugangskontrolle.

    Und ich betreue insgesamt 11 Sites, wobei nicht alle auf WP Basis sind. Sollte aber der Link tatsächlich nötig sein, stelle ich ihn auch rein. Die Betreiber kommen hier wahrscheinlich eh nicht vorbei …

    Meist betreffen meine Fragen aber wie gesagt, Sites in Entwicklung uo. gleich so viele, das ein Link nicht reicht.

    Ok, es gäbe Plugins, ist mal gut zu wissen, falls der Kunde doch drauf besteht.

    Ja, früher fand ich das „cool“, habe das gerne umgesetzt, doch seit der Smartphone Ära eben nicht mehr so. Da schalte ich auch unter besonders kleinen Schirmen das Headerbild weg, ersetze es mit einem Farb-Hintergrund.

    Eine andere Spielerei, diese Parallax Effekte mag ich auch, wenns wo passt. Aber auch da ist das nur bis zum ipad ok. Darunter auch nicht mehr so.

    Jedenfalls Danke!

    Das mit der Übersetzung hab ich jetzt nicht ganz gecheckt.

    Aber wurst, bin froh das eigentliche Prob gelöst zu haben – Danke!

    Die Sache ist nun zu 95% gelöst.
    Denn ich habe nun noch den Auszugslängen-Wert, welcher per Customizer gewählt wird, gefunden und die Var ausgelesen.
    Ebenso die dort eingestellten Zeichenfolge für den More Link.

    add_filter( 'category_description', 'cyb_trim_category_desc', 10, 2 );
    function cyb_trim_category_desc( $desc, $cat_id ) {
      if ($_GET["rm"]!=1) {
        $desc = wp_trim_words( $desc, magazine_excerpt_length($length), '<a href="' . get_category_link( $cat_id ) . '?rm=1">' . magazine_excerpt_more() . '</a>' );
      }
        return $desc;
    }

    Bleibt nur die zweiteilige Frage zum Code von https://wordpress.stackexchange.com/questions/202489/how-to-customize-category-description/202491#202491:
    1.) Warum tut der zwei Unterstriche „__“ vor „Read More“?
    Hab die weggelöscht, für was soll das gut sein – und Fehler! (syntax error, unexpected ‚,‘ in )
    2. Was ist mit „text-domain“ gemeint?

    So, das klappte!

    Hab einfach den Parameter „rm=1“ an den Link zur Kategorie angehängt und nach der pos. Abfrage ob rm nicht 1 ist, wird gekürzt. 1 ist nur da, wenn eben vom „Read More“ Link aufgerufen. Nicht aber wenn die Kategorie übers normale Menü aufgerufen wird.

    add_filter( 'category_description', 'cyb_trim_category_desc', 10, 2 );
    function cyb_trim_category_desc( $desc, $cat_id ) {
      if ($_GET["rm"]!=1) {
        $desc = wp_trim_words( $desc, 55, '<a href="' . get_category_link( $cat_id ) . '?rm=1">' . __("Read more", "text-domain" ) . '</a>' );
      }
        return $desc;
    }

    Danke fürs Suchen, bin eben auch dabei, fand aber nichts.

    Dieser Code ist meinen laienhaften Versuchen (Erfolg: 25%) ähnlich, funzt aber schon zu 50%. Denn:
    Wenn man die Kategorie (deren Beschreibung nun echt als Teaser kommt!) aus dem „Read More“ Link aufruft, wird sie natürlich wieder verkürzt dargestellt.

    Hier müsste man evtl. einen Parameter mitgeben, der besagt: Du bist jetzt nicht auf dem normalen Weg aufgerufen worden, sondern von dem weiterlesen Link. Oder so …

    Danke, aber das klappt beides nicht.

    Weder das Plugin, noch der Code hat Einfluss auf die Kategorienbeschreibung.

    Der Code ändert zudem auch nirgends die Auszugslänge. Obwohl im Parent-Theme das überschreiben der excerpt_length (durch die Child functions.php) möglich ist.

    Auch der Code (zusammengebastelt aus deinem Tipp und dem aus der Referenz) funzt nicht:

    add_filter( 'excerpt_length', 'category_excerpt_length', 999 );
    function category_excerpt_length( $length ) {
      if ( is_category () ) {
        return 100;
      }
      return $length;
    }
    Forum: Allgemeine Fragen
    Als Antwort auf: upgrade.php

    stimmt auch wieder …

Ansicht von 15 Antworten - 31 bis 45 (von insgesamt 314)