Verfasste Forenbeiträge

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 47)
  • Thread-Starter Rolf

    (@rolinux)

    Ich habe den upgrade-Ordner geleert, mich aus dem WP-Backend abgemeldet und den Browsercache gelöscht. Dann das Update neu gestartet, aber es hängt jetzt immer noch seit ca. 1/2 Std.

    Allerdings steht nichts neues in der error.log.

    Gruß
    Rolf

    • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von Rolf.
    Thread-Starter Rolf

    (@rolinux)

    Ich habe WP Super Cache installiert und jetzt umbenannt und -xxx an den Verzeichnisnamen angehängt.
    Aber das Update scheint immer noch nicht zu funktionieren. Die WP-Dateien werden brav runtergeladen, aber dann passiert nichts mehr. In der error.log steht immer noch der gleiche Fehler.

    Die Homepage funktioniert nach wie vor. Das Abmelden aus dem Backend und erneuter Start des Updates scheint also keine Auswirkungen zu haben.

    Gruß
    Rolf

    • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von Rolf.
    Thread-Starter Rolf

    (@rolinux)

    Ich habe noch php 7.4 laufen. Wird aber demnächst von udmedia auf 8.0 aktualisiert.
    Bisher hatte ich noch Probleme mit der 8.0 und WP, deshalb habe ich so lange mit dem Update von WP gewartet. Aber jetzt muss ich das angehen, weil ich hoffe, dass damit die php-8-Probleme behoben sind, nachdem jetzt auch die meisten meiner WP-Plugins auf WP 6.x laufen.

    Gruß
    Rolf

    Thread-Starter Rolf

    (@rolinux)

    Update:
    Ich habe grade die Datei error.log gefunden. Da steht ganz am Ende:

    `[12-Nov-2022 11:46:44 Europe/Berlin] PHP Fatal error: Uncaught Error: Call to undefined function create_function() in …/wp-includes/SimplePie/Cache/.49d0df85.ico:2
    Stack trace:
    #0 …/wp-config.php(4): include()
    #1 …/wp-load.php(50): require_once(‚…‘)
    #2 …/wp-blog-header.php(13): require_once(‚…‘)
    #3 …/index.php(17): require(‚…‘)
    #4 {main}
    thrown in …/wp-includes/SimplePie/Cache/.49d0df85.ico on line 2`

    Kann das das Problem sein?

    Gruß
    Rolf

    • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von Rolf.
    • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von Rolf.
    • Diese Antwort wurde geändert vor 1 Jahr, 3 Monaten von Rolf.
    Forum: Plugins
    Als Antwort auf: Title Remover und WP 6
    Thread-Starter Rolf

    (@rolinux)

    CSS ist mir geläufig. Danke für den Tipp. Das Problem ist nur, dass ich den Titel nur bei manchen Beiträgen, nicht aber bei Seiten ausblenden möchte. Muss ich mir mal anschauen, ob ich das mit CSS differenzieren kann.

    Gruß
    Rolf

    Forum: Plugins
    Als Antwort auf: Welches Plugin wird wo verwendet?
    Thread-Starter Rolf

    (@rolinux)

    Hallo,

    mit php kenne ich mich nicht aus. HTML/CSS geht da schon besser. Meine ersten Homepage-Versuche waren direkt im HTML-Editor. Auf CMS habe ich erst später umgestellt. Das war damals moziloCMS, das ich immer noch gut finde, weil es keine Datenbank braucht. WordPress kam viel später dazu (2018), weil ich eine Homepage mit moziloCMS in der notwendigen Form nicht mehr machen konnte.

    ich habe den Plugin Report installiert. Das ist ja schon mal recht informativ. Man muss damit nicht mehr alle Plugins durchklicken, um rauszufinden, welche Plugins veraltet sind.
    Aber eine Übersicht, wo ich welches Plugin in meiner Homepage verwende, bekomme ich so nicht. Und das ist ja auch wichtig, wenn ich veraltete Plugins ersetzen möchte. „Einfach“ eine Liste, welches Plugin auf welcher Inhaltsseite verwendet wird.

    Gruß
    Rolf

    Thread-Starter Rolf

    (@rolinux)

    Vielen Dank für Eure Antworten, Hinweise und Tipps.

    Ich habe das 2FA-Plugin Two Factor auch schon installiert und nutze es jetzt.
    Mein Passwort ist natürlich nicht einfach nur 1234asdf oder sowas.
    Das Plugin zum Umleiten des Plugin-Pfades habe ich ausgetauscht. WPS Hide Login ist zwar lt. Plugin-Liste noch ungetestet mit WP 5.9.2, aber es ist zumindest neuer als mein bisher verwendetes Plugin und ich hege die Hoffnung, dass das Plugin demnächst ein entsprechendes Update erfährt.

    Im Moment nutze ich zusätzlich noch reCaptcha für die Absicherung des Backend-Login. Aber ich denke, dass ich das abschalten werde. Das wird dann doch eher lästig mit den Bildchen, vor allem, wenn bereits bestätigte Bildchen durch neue Bildchen ersetzt werden. Außerdem kann man es mit der Sicherheit auch übertreiben. Wenn die Anmeldung mal länger dauert als die Pflege der Homepage…

    Gruß
    Rolf

    Thread-Starter Rolf

    (@rolinux)

    2FA ist natürlich reizvoll. Auf die Idee bin ich noch nicht gekommen.

    Aber ich verstehe nicht ganz, wie das Plugin funktioniert. E-Mail-Code ist, glaube ich, klar. Da wird einfach nur eine E-Mail mit einem Einmalcode verschickt. Was allerdings auch nicht ganz so sicher ist, meine ich, denn eine E-Mail kann abgefangen werden. Aber wo wird der QR-Code angezeigt? Denn direkt beim Login scheint mir das nicht sehr sinnvoll zu sein. Aber wenn woanders, brauche ich ja drei Geräte: Den Rechner, über den ich mich anmelden will, ein Gerät, wo der QR-Code angezeigt wird und ein Gerät, mit dem ich den QR-Code scanne.

    Macht das Plugin das dann nur fürs Backend oder auch für die User, die sich im Mitgliederbereich der Homepage anmelden? Kann man das steuern?

    Gruß
    Rolf

    Thread-Starter Rolf

    (@rolinux)

    Die Error-Logs des Servers hatte ich auch schon bei dem weiße-Seite-Problem geprüft und meinen Hoster gefragt. Daraus war nichts zu entnehmen.
    Debugging bzw. Protokollierung mit htaccess und anderem hatte ich auch schon bei dem weiße-Seiten-Problem versucht und kein Ergebnis bekommen, was ich da auch geschrieben hatte.
    Dass JetPack nicht DSGVO-konform ist, wurde da auch schon geschrieben. PHP Server Monitor kann ich mir mal anschauen.
    Den Seitenzustand in WordPress zu prüfen, ist im Moment des Ausfalls leider nicht möglich, weil ich dann auch nicht ins Backend komme. Und wenn die Seite dann wieder läuft, ist alles ok lt. dieser Prüfung.
    Nicht genutzte Plugins und Themes habe ich auch schon vor einiger Zeit gelöscht.

    Gruß
    Rolf

    Thread-Starter Rolf

    (@rolinux)

    @hage:

    Hallo,

    wg. dieser ganzen für mich unverständlichen E-Mail von time.ly hatte ich in den letzten Wochen auch schon erwogen, auf The Events Calendar umzusteigen.

    Mir ist aber nicht ganz klar, ob ich damit in der kostenlosen Version auch eine Terminliste anzeigen kann statt einer Kalenderansicht. Und für die Shortcodes zur Einbindung auf der Homepage habe ich gelesen, dass man dafür ein zusätzliches Plugin braucht.

    Gruß
    Rolf

    Thread-Starter Rolf

    (@rolinux)

    Hallo,
    kurzes Update:
    Ich habe mich vorletzte Woche wie geraten an meinen Hoster gewendet wg. der Protokolle. Der konnte mir dazu aber auch nichts sagen, hat mir aber ein paar Tipps gegeben. Einer davon war, ein Plugin zu installieren, das den Seiteninhalt cached. Vor ca. 10 Tagen habe ich auf diese Empfehlung hin das Plugin „WP Super Cache“ installiert, seither habe ich das beobachtet und hatte keine weiße Seite mehr.
    Es scheint dadurch also behoben zu sein.
    Vielen Dank für Eure Hilfe und die Tipps.
    Gruß
    Rolf

    Thread-Starter Rolf

    (@rolinux)

    Ich habe auch schon versucht, Logfiles zu erzeugen, wie ich oben geschrieben habe. Das habe ich so gemacht wie es bei meinem Hoster udmedia geschrieben habe. Es wurden keine Logfiles erstellt. Also kann ich Euch damit leider nicht dienen.

    Gruß
    Rolf

    Thread-Starter Rolf

    (@rolinux)

    Ich habe jetzt alles mal ausprobiert, was hier genannt wurde.
    Wenn ich das Plugin-Verzeichnis per FTP umbenenne und ein neues erstelle, wird mir auf der Seite ein Fehler angezeigt mit dem Link zu wordpress.org, wo steht, dass man per phpmyadmin die Plugins deaktiveren soll im Eintrag wp-options. Auch das habe ich gemacht, aber da wird mir auch im Backend nichts brauchbares angezeigt, nur dass ein Fehler passiert ist und der Link auf ebendiesen phpmyadmin-Eintrag.

    Auch Debugging führt zu nix. Da wird mir nichts angezeigt und auch keine Logdatei geschrieben.

    Die Homepage wird nach wie vor manchmal weiß angezeigt, also gar nicht. Auch keine Fehlermeldung. Dann funktionierts wieder für ein paar Tage, ohne dass irgendwas passiert ist. WordPress und die Plugins werden automatisch aktualisiert und ich bekomme jedes Mal eine E-Mail nach so einer Aktualisierung. Aber nicht jedes Mal hat eine Aktualisierung stattgefunden, wenn die Seite wieder funktioniert.

    Ich kann mir irgendwie nicht vorstellen, dass es an irgendwas in den Plugins liegt. Denn Fehler in den Plugins müssten ja dauerhaft zu Problemen führen und nicht ab und zu. Auch ein Fehler in den Daten der Plugins müsste dauerhafter zu Problemen führen. Außerdem dürfte ich dann ja gar nicht mehr an die Homepage rankommen, wenn es ein von mir in den Daten erzeugter Fehler wäre. Denn den könnte ich dann ja nie wieder reparieren.

    Im Hintergrund scheint weiter alles zu funktionieren, zumindest werden die automatischen Updates für WordPress und die Plugins installiert, auch wenn die Homepage selber weiß angezeigt wird.

    Einen Verdacht habe ich noch: Ich verwende den time.ly-Kalender. Der scheint ja mittlerweile kostenpflichtig zu sein. Zumindest habe ich im Dezember 2021 eine merkwürdige E-Mail von denen bekommen (ich vermute mal, dass das von time.ly kam, so ganz sicher bin ich mir da nicht), dass ich meinen Account updaten soll, da sie mir sonst den Account deaktivieren würden und keine Account-Updates mehr bereitstellen könnten. Was auch immer das bedeutet. War auf englisch, und mein englisch ist nicht so gut.

    Dafür könnte ich mal einen Ersatz installieren und probieren. Allerdings müsste auch das zu dauerhafteren Problemen führen, weil so ein Account ja auch eher dauerhaft deaktiviert wird und nicht tageweise. Außerdem verwendet mein Sohn bei seiner Vereinshomepage ebenfalls dieses Plugin und hat keine Probleme. Er verwendet sowieso fast überall die gleichen Plugins wie ich (er hat mir die meisten davon empfohlen) und hat keine Probleme.

    Gruß
    Rolf

    Thread-Starter Rolf

    (@rolinux)

    Naja, das Problem ist ja eben, dass es mal funktioniert und dann wieder nicht, jeweils ohne dass dazwischen was passiert wäre. Ich weiß also nicht, wie lange dieser Zustand anhält. und dafür hätte ich gerne eine Erklärung. Ich habe auch schon gedacht, dass es vlt. der Browser ist (Firefox in aktueller Version), aber der Edge zeigts genauso an. Und der hat ja eine andere Engine als der FF.

    Aber die Datenschutzprobleme des Plugins Jetpack brauchen wir hier nicht zu erörtern. Zumal in der Datenschutzerklärung der HP Jetpack erwähnt wird.

    Gruß
    Rolf

    Thread-Starter Rolf

    (@rolinux)

    Jetzt habe ich zwei Tage lang die Datei error.log laufen. Vorgestern, als ich es eingerichtet habe, wurde die Homepage noch weiß angezeigt, seit gestern wird sie wieder richtig angezeigt.
    In der Datei error.log steht aber nichts drin. Ich habs so eingestellt, wie es bei udmedia erklärt wird. Also scheint es sich nicht um einen php-Fehler zu handeln. Ich habe die Seite vorgestern, als die Datei eingerichtet war, ja auch mehrmals aufgerufen. Also müsste was in der Datei stehen, wenn es sich um einen php-Fehler handeln würde.
    Was kann es noch sein?

    Gruß
    Rolf

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 47)