Verfasste Forenbeiträge

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das Problem hat etwas mit der MySQL Datenbank zu tun.

    Ausgangs Situation: Ich sah die „alten“ Bilder in der Mediathek, aber Bilder die ich neu hochgeladen habe, sah ich nicht. Die neuen Bilder wurden aber in den Ordner wp-content/uploads gespeichet.

    Nachdem ich in der Datenbank in der Tabelle wp-1options in der Zeile: image_default_link_type den Wert „file“ eingetragen hatte, weil dieser Wert bei der funktionierenden Installation drin stand, verschwanden in der Mediathek auch alle „alten“ Bilder obwohl sie noch im Ordner wp-content/uploads da waren. Für mich ein Rätsel. Das Problem ließ nich dann auch nicht mehr Rückgängig machen, nachdem ich den Wert wieder entfernt hatte.

    phpMyAdmin Datenbankfehler:

    Fehlermeldung bei phpMyAdmin: Die aktuelle Markierung enthält keine eindeutige („unique“) Spalte. Gitter-Bearbeitungsfunktion, Kontrollkästchen, Bearbeiten, Kopieren und Löschen von Links sind nicht verfügbar.

    Fehlermeldung bei WordPress (WP_DEBUG true): WordPress database error: [Duplicate entry ‚0‘ for key ‚PRIMARY‘]

    In Foren habe ich über das Thema UNIQIE KEY und PRIMARY KEY gelesen, aber das ganze hat mich nur noch mehr verwirrt und nicht wirklich weitergebracht.

    Meine eigene Lösung:

    Ich habe auf meinem lokalen Server (iMac) eine älteres Backup der Webseite installiert und siehe da alles funktioniert prima. Ich muss nur die fehlenden Artikel und Änderungen nachtragen, aber das ist zum Glück nicht so viel. Damit endet für mich die Suche nach dem genauen Fehler und dem WARUM, irgendwie ist die Datenbank fehlerhaft, keine Ahnung warum und wie und da ich keine große Ahnung von MySQL habe um die Datenbank zu reparieren, endet der Beitrag für mich hier.

    Meine Lösung und mein Tipp für alle: Regelmäßig Backups machen!!! Ich nutze dazu das kostenlose Plugin: BackWPup und Dropbox. Zusätzlich kopieren ich mir immer wieder mal die Backups von Dropbox auf meinen PC und eine externe Festplatte. Mit einem funktionierenden Backup kann man die Webseite im Notfall wiederherstellen und anpassen (Permalink, Theme Einstellungen, Einstellungen von einzelenen Plugins usw.)

    Danke Torsten für deine ausführliche Antwort, Du gibst dir wirklich viel Mühe und das schätze ich, da hast du ein großes Lob verdient.

    Die Regeln sind nun mal von Forum zu Forum etwas anders. Bei anderen Foren wurden meine Fragen schon gelöscht, weil es hieß: „Erst die Suche nutzen ob die Frage schon mal gestellt wurde“. Seit dem nutze ich immer zuerst die Suche Funktion in Foren und wenn ich meine Frage finde klinke ich mich in das Thema ein, so habe ich es auch hier gemacht, daher kam es zu diesem Missverständnis, aber jetzt ist ja alles wieder in Butter und ich habe ein neues Thema begonnen: hier falls es jemand interessiert.

    Ich habe die Webseite mit dem Duplicator Plugin auf meinen lokalen Server geladen und habe das gleiche Problem. Aber ich werde Morgen ein Backup auf eine Subdomain hochladen und ein wenig testen. Ich lege zuerst eine neue Datenbank an und prüfe ob der Upload in der Mediathek funktioniert, dann importiere ich die alte Datenbank. Ich habe mehrere Backupdateien zur Verfügung die ich mit dem Plugin BackWPup auf Dropbox geladen habe. Sobald ich neue Erkenntnise haben und weiß woran es gelegen hat, werde ich es hier posten.

    Die Seite ist: http://www.ballicu-sanierung.de

    Maximaler Upload für Dateien beim Hoster und online Installation sind lt. WordPress Installation 8 MB (Angabe aus der Mediathek).

    Bei meiner lokalen Installation sind es 32 MB.

    Beides.

    Der Hoster hat alle Rechte auf 777 gestellt um zu sehen ob das Problem von WordPress an den Zugriffsrechten liegt oder nicht. Lag aber nicht an den Zugriffsrechten. Ich kann die Zugriffsrechte auch selbst beim Hoster einstellen. Das habe ich schon ausgetestet, leider ohne Erfolg.

    Ich habe die komplette WordPress Installation + Datenbank heruntergeladen und die komplette Webseite lokal auf meinem iMac über MAMP installiert, hier zeigt sich genau der gleiche Fehler, wie kann das sein? Irgendwie muss diese WordPress Installation bzw. Webseite einen Fehler haben.

    Wenn der Fehler nicht lokalisiert und gefunden wird komme ich wohl um einen neue Installation nicht herum, das ist aber leider viel viel Arbeit 🙁

    Beim Hoster habe ich unbegrenzten Speicher (also mehrere GB) und 128 MB Arbeitsspeicher wurde der Webseite zugewiesen die auf PHP 5.4.38 läuft. Die Webseite selbst hat ca. 40 MB, also nicht wirklich viel. Auf meinem lokalen Server (PHP 5.6.2) habe ich 1000GB Speicherplatz und auch 128MB Arbeitsspeicher über PHP für den Server zugewiesen.

    JA Speicher habe ich mehr als genug, ich denke nicht das es daran liegt.

    Auch Bilder die ich bereits schon mal auf die Webseite hochgeladen habe, lassen sich nicht mehr hochladen. Es liegt also auch nicht an den Bilder und den Pixeln und der größe der Bilder den die haben nur 100 – 200 KB und ca. 500×300 Pixel.

    @torsten: Ich verstehe deine Bitte zwar nicht, aber wenn du meinst – von mir aus. 1. Denke ich das gehört zum Thema 2. „hijacken“ kann man das in einem deutschen Forum nicht auch auf deutsch ausdrücken. 3. oder meinst du ich soll explizit für MEINE Frage (auch wenn es das gleiche Thema ist) mein EIGENES Thema eröffnen? Wenn so die Regeln sind – Bitteschön.

    Manchmal ist so ein Forum wie die kleinen Missverständnisse zwischen Mann und Frau – auf die richtige Kommunikation und Ausdrucksweise kommt es an!

    –> neues Thema eröffnet.

    Für allen, hier nochmal ganz klar beschrieben um was für ein Problem es genau geht:

    Fehlermeldung: „Bei dem Upload ist ein Fehler aufgetaucht. Probiere es später noch einmal.“

    Bei WordPress 4.2.x funktioniert die Mediathek nicht mehr richtig. Bilder die man über die Mediathek oder in Beiträgen hochladen will, werden nicht in der Mediathek angezeigt um diese dann in den Beitrag einzufügen. Die Bilder werden zwar hochgeladen (wp-content/uploads)können in der Mediathek aber nicht genutzt werden, weil sie dort nicht angezeigt werden.

    Aus meiner Sicht muss es sich um ein WordPress Problem handeln und nicht um ein PHP oder Hoster Problem. Ich bin weder bei Strato noch bei 1und1. Bei mir tritt dieses Problem sowohl bei einer Online Installation, als auch bei einer Installation auf einem lokalen Server auf, es liegt also nicht an der neusten PHP Version, denn die habe ich (PHP 5.6), es liegt auch nicht am mangelnden Server Speicher denn ich habe 128MB was völlig ausreichend ist.

    Ich habe mehrere WordPress Webseiten beim gleichen Hoster, sogar unter der gleichen IP, aber nur bei einer tritt seit kurzem dieser „spezielle“ Fehler auf.

    Lösungen die bei mir NICHT funktioniert haben:

    – Alle Plugins deaktivieren
    – wp-config.php mit den Befehlen define(WP_TEMP_DIR….wp-content) und define(WP_MEMORY_LIMIT…) „modifizieren“
    – Plugin: „resize images before upload“ installieren
    – Plugin: „Add From Server“ nutzen
    – .htaccess Datei löschen
    – verschiedene Browser verwenden
    – WP Verzeichnisrechte per FTP auf 755 bzw. 777 ändern

    Auch mein Hoster konnte mir bis jetzt nicht weiterhelfen, ich bin echt am verzweifeln, wenn ich keine Lösung finden bleibt mir wohl nichts anderes übrig, all die komplette Webseite neu aufzusetzen 🙁

    Ich hoffe auf eure Hilfe.

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)