Verfasste Forenbeiträge

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Hallo Leute,

    hab selber grad mit dem Problemchen gekämpft und bin auf den Beitrag gestoßen. Gebt einfach mal bei den Nutzungsgrenzen (Nutzungslimit pro Gutschein und Nutzungslimit pro Benutzer) einen Zahlenwert ein – dann funktioniert das auch im Backend wieder! 😉

    Viele Grüße,
    Christoph

    Thread-Starter vogography

    (@vogography)

    Ich dank Euch allen für Euren Input und die Hilfe! Habe das nun bekannte Problem auch schon den Plugin-Entwicklern mitgeteilt und inzwischen die betreffende Datei manuell korrigiert. Funktioniert – zumindest bis zum nächsten Update 😉

    @edi: Ich verstehe schon, was Du meinst. Allerdings ist mein Shop auch nicht unbedingt groß, sondern es geht einfach darum z.B. ein paar Gutscheine oder Bilder online anzubieten. Keine großen Produkt-Sortimente und dergleichen und so ist das für mich irgendwie fein, wenn alles von einer Stelle gesteuert werden kann.

    Thread-Starter vogography

    (@vogography)

    @gantry:
    Hab ich gepostet – danke!

    Thread-Starter vogography

    (@vogography)

    @monika:
    Ich denke, das sollte kompatibel sein!?

    Habe bei JCH auch den Cache geleert und dann das Plugin deaktiviert – kein Erfolg.

    Interessant finde ich, dass wenn ich die Datei „page.php“ kopiere und danach in „woocommerce.php“ umbenenne, das Design wieder passt – sprich, es wird der Header, der Content-Bereich und der Footer an der richtigen Position angezeigt.

    Allerdings ist im Content-Bereich dann kein Inhalt (also keine Produkte) vorhanden. Es ist nur eine leere Seite.

    Meiner Logik nach sollte ich jetzt einfach irgendwie den benötigten Inhalt in diesen Content-Bereich bringen. Mit dem Einfügen der Zeile <?php woocommerce_content(); ?> in die woocommerce.php funktioniert das aber leider nicht, weil dann die Seite nicht mehr erreichbar ist und diese Fehlermeldung ausgiebt:
    Parse error: syntax error, unexpected ‚<‚ in …/woocommerce.php on line 41

    Thread-Starter vogography

    (@vogography)

    Ich benutze das Plugin JCH Optimize Pro. An der Darstellung ändert sich aber auch nichts, wenn das Plugin deaktiviert ist.
    Es ist auch keine woocommerce.php vorhanden – diese hatte ich nur zur in dem obigen Link beschriebenen Lösung des Problems angelegt und wieder gelöscht, weil es nicht funktioniert hat.

    Wenn eine woocommerce.php mit gleichem Inhalt wie die page.php vorhanden ist, dann passt das Design, jedoch wird kein Shop-Inhalt angezeigt.

    Wenn keine woocommerce.php (mit gleichem Inhalt wie die page.php) vorhanden ist, dann schaut das Design so aus, wie’s momentan ausschaut … mit dem Header auf der rechten Seite irgendwo mittem im Bild usw.

    Thread-Starter vogography

    (@vogography)

    Die Theme-Dateien sollten eigentlich alle vorhanden sein. Ich verwende das ISOTOPE-Theme mit dem Gantry 5 Framework. Da ist auch alles aktuell. Habe im Netz das hier gefunden, allerdings haben mich auch diese beiden Lösungsansätze nicht weiter gebracht.

    https://docs.woothemes.com/document/third-party-custom-theme-compatibility/

    Die 2. Methode bringt gar keine Veränderung.

    Bei der 1. Methode passiert folgendes:

    Wenn ich die page.php kopiere und in woocommerce.php umbenenne, wird die Seite vom Aufbau her richtig dargestellt. Das heißt, Header, Content und Footer sind an der richtigen Position und stimmen mit den restlichen Seiten überein. Allerdings wird der Seiten-Inhalt (Das Produkt) nicht dargestellt.

    In der php-Datei ist kein Loop vorhanden:

    <?php if ( have_posts() ) :

    <?php endif; ?>

    und wenn ich die Zeile <?php woocommerce_content(); ?> einfüge, dann bekomme ich beim Aktualisieren der Seite diese Fehlermeldung:

    Parse error: syntax error, unexpected ‚<‚ in …/woocommerce.php on line 41

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)