Verfasste Forenbeiträge

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Wie wird denn die Funktion theme_enqueue_styles() eingebunden?
    -> Leider weiß ich nicht, was das bedeutet. Die Funktion wurde so, wie von mir oben beschrieben in einem Youtube-Video angewandt. Mich wundert, dass es bei einem Menüpunkt funktioniert hat, ansonsten aber nicht geht.

    add-action( ‚wp_enqueue_scripts‘, ‚theme_enqueue_styles‘ )
    ->` Habe ich nicht eingebaut. Meinst du im HTML-Kopf?


    Ich habe es nochmal mit der Anleitung von Font Awesome versucht:
    1. Funktion aus functions.php gelöscht
    2. Auf die entsprechende Seite folgenden Inhalt eingefügt:

    <head>
      <link href="/wp-content/themes/Impreza-child/css/fontawesome.min.css" rel="stylesheet">
    </head>

    Auch das funktioniert leider nicht. Ich dachte auch, dass ich das Einbinden der CSS-Datei einmal komplett für die Webseite einrichten kann, damit ich anschließend bei Bedarf nur noch

    <i class=“fas fa-home fa-lg“ style=“color:#2786ed“></i>

    einfügen muss.

    Auch die Erklärungen in meinem Buch „HTML5 und CSS3“ von Jürgen Wolf helfen mir leider nicht weiter … langsamm verzweifelt ich. Das kann doch nicht so schwer sein? Vielleicht hast du ja nochmal einen Tipp. Ansonsten Danke für deine Mühe!

    • Diese Antwort wurde geändert vor 1 Jahr, 10 Monaten von w7x7w.
    • Diese Antwort wurde geändert vor 1 Jahr, 10 Monaten von w7x7w.
    w7x7w

    (@w7x7w)

    In den allgemeinen Einstellungen war tatsächlich hinter der einen URL https://example.de noch „/startseite“ eingegeben. Nach dem Löschen von „/startseite“ und dem Auswählen einer schönen Permalink-Struktur funktioniert nun alles: Alle Links und Seiten funktionieren einwandfrei!

    Super! Das ich das nach ewigem Gucken nicht bereits selber gefunden habe ist echt peinlich. Ich bedanke mich recht herzlich für die tolle Unterstützung!!!!

    w7x7w

    (@w7x7w)

    Ich habe eben nochmal geschaut:

    auch, wenn ich auf den Permalink klicke, der auf der Seite „Startseite“ im CMS angegeben ist, kommt die gleiche Fehlermeldung:

    Not Found

    The requested URL /startseite/ was not found on this server.

    Falls das noch relevant ist.

    w7x7w

    (@w7x7w)

    Hallo @pixolin

    ausgewählt ist folgende Permalinkstruktur ausgewählt:
    https://wegweiser-karriere.de/startseite/?p=123

    Die Seite „Startseite“ hat allerdings folgenden Permalink angegeben: https://wegweiser-karriere.de/startseite/?page_id=34

    Für mich als Neuling sieht das so aus, als sei da schon was faul!?

    Mein Webserver (one.com) unterstützt mod-rewrite, soweit ich weiß. Allerdings habe ich in meinem FTP-Programm keine „.htaccess-Datei“ in welcher eine andere Weiterleitungsregel existiert, als die in meinem anderen Post:

    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

    Die Weiterleitungsregel von http nach https funktioniert auch einwandfrei. Kannst du mit meinen Angaben etwas anfangen?

    w7x7w

    (@w7x7w)

    Hallo @pixolin

    Danke für deine Hilfe. Tut mir Leid, ich werde zukünftig alles geben, um bessere Hinweise zu geben.

    Du hast allerdings richtig vermutet:
    – Webseite- und WordPress-URL hatte ich noch nicht umgestellt gehabt!
    – Das Tool „Better Search Replace“ hat noch 3 Änderungen vornehmen können

    Die Rewrite-Regel habe ich allerdings in eine neue „.htaccess-Date“ eingefügt, da in meinem FTP-Programm (File Manager) bisher keine solche Datei vorhanden war. Habe nach deinem Post vorhin extra nachgeguckt, konnte jedoch nix finden.

    Für Jemanden, der ähnliche Fehler hat wie ich, kann ich noch folgende Anleitung empfehlen, die mit zahlreichen Screenshots versehen ist und die Tipps von @pixolin alle beinhaltet: https://www.elmastudio.de/wordpress-webseiten-auf-https-umstellen-leicht-gemacht/

    Vielen Dank fr die unglaublich schnelle und kompetente Hilfe!!!

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)