{"id":47962,"date":"2018-04-24T00:16:36","date_gmt":"2018-04-23T22:16:36","guid":{"rendered":"https:\/\/de.wordpress.org\/support\/topic\/fehler-nach-update-auf-php-7-2\/"},"modified":"2018-04-24T00:16:36","modified_gmt":"2018-04-23T22:16:36","slug":"fehler-nach-update-auf-php-7-2","status":"publish","type":"topic","link":"https:\/\/de.wordpress.org\/support\/topic\/fehler-nach-update-auf-php-7-2\/","title":{"rendered":"Fehler nach Update auf PHP 7.2"},"content":{"rendered":"<p>Moin,<\/p>\n<p>ich habe auf mehreren selbstgehosteten Seiten den Spa\u00df, dass Fehler auftauchen. Nachdem goneo PHP 7.2 nun anbietet habe ich dieses f\u00fcr verschiedene Instanzen aktiviert. Bis dato liefen die Seiten auf 7.1, ohne entsprechende Meldungen.<\/p>\n<p>Alle Instanzen laufen auf <strong>Version 4.9.5<\/strong><\/p>\n<p>Zun\u00e4chst hat die Multisite folgende Fehler:<\/p>\n<pre><code>Warning: Use of undefined constant \ufffdSUNRISE\ufffd - assumed &#039;\ufffdSUNRISE\ufffd&#039; (this will throw an Error in a future version of PHP) in \/**SHORTED**\/wp-config.php on line 92\nWarning: Use of undefined constant \ufffdon\ufffd - assumed &#039;\ufffdon\ufffd&#039; (this will throw an Error in a future version of PHP) in \/**SHORTED**\/wp-config.php on line 92<\/code><\/pre>\n<p>Das konnte durch den Austausch der &#8218; korrigiert werden. Was jedoch lediglich einen neuen Fehler erzeugt:<\/p>\n<pre><code>Warning: include_once(\/data\/web\/1\/000\/065\/143\/266345\/htdocs\/network\/wp-content\/sunrise.php): failed to open stream: No such file or directory in \/**SHORTED**\/wp-includes\/ms-settings.php on line 47\n\nWarning: include_once(): Failed opening &#039;\/data\/web\/1\/000\/065\/143\/266345\/htdocs\/network\/wp-content\/sunrise.php&#039; for inclusion (include_path=&#039;.:\/usr\/local\/phpfarm\/inst\/php-7.2.2\/lib\/php\/&#039;) in \/**SHORTED**\/wp-includes\/ms-settings.php on line 47<\/code><\/pre>\n<p>Die dort angesprochene Zeile ist der Verweis auf die sunrise.php<br \/>\n<code>include_once( WP_CONTENT_DIR . &#039;\/sunrise.php&#039; );<\/code><\/p>\n<p>diese liegt gem\u00e4\u00df Installation unter .\/wp-content\/plugins\/wordpress-mu-domain-mapping\/sunrise.php<\/p>\n<p>Neben diesem Multisite Fehler werfen auch die einzelnen Instanzen folgenden Fehler:<\/p>\n<p><code>Deprecated: Directive &#039;track_errors&#039; is deprecated in Unknown on line 0<\/code><\/p>\n<p>Das scheint soweit bereits an unterschiedlichen Stellen referenziert eine Meldung aus der php.ini des Hosters zu sein.<\/p>\n<p>Es kann soweit sichtbar alles ge\u00f6ffnet werden, aber eben nicht Fehlerfrei und ich w\u00fcrde gerne langfristige Probleme ausschlie\u00dfen.<\/p>\n<p>Daher die Fragen:<br \/>\n* Sind die Probleme mit PHP 7.2 bekannt?<br \/>\n* gibt es entsprechende L\u00f6sungen?<\/p>\n","protected":false},"template":"","class_list":["post-47962","topic","type-topic","status-publish","hentry","topic-tag-deprecated","topic-tag-php-7-2","topic-tag-update"],"jetpack_sharing_enabled":true,"_links":{"self":[{"href":"https:\/\/de.wordpress.org\/support\/wp-json\/wp\/v2\/topic\/47962","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/de.wordpress.org\/support\/wp-json\/wp\/v2\/topic"}],"about":[{"href":"https:\/\/de.wordpress.org\/support\/wp-json\/wp\/v2\/types\/topic"}],"version-history":[{"count":0,"href":"https:\/\/de.wordpress.org\/support\/wp-json\/wp\/v2\/topic\/47962\/revisions"}],"wp:attachment":[{"href":"https:\/\/de.wordpress.org\/support\/wp-json\/wp\/v2\/media?parent=47962"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}