Advanced Automatic Updates

Beschreibung

Advanced Automatic Updates adds extra options to WordPress‘ built-in Automatic Updates feature. On top of security updates, it also supports installing major releases, plugins, themes, or even regular SVN checkouts!

If you’re working on a WordPress Multisite install, it will properly restrict the options page to your Network Admin.

While this will be useful for the vast majority of sites, please exercise caution, particularly if you have any custom themes or plugins running on your site.

Screenshots

Installation

The Good Way

  1. In your WordPress Admin, go to the Add New Plugins page
  2. Search for: advanced automatic updates
  3. Advanced Automatic Updates should be the first result. Click the Install link.

The Old Way

  1. Upload the plugin to the /wp-content/plugins/ directory
  2. Aktiviere das Plugin mittels dem ‚Plugins‘-Menü in WordPress

The Living-On-The-Edge Way

(Please don’t do this in production, you will almost certainly break something!)

  1. Checkout the current development version from https://plugins.svn.wordpress.org/automatic-updater/trunk/
  2. Subscribe to the RSS feed to be notified of changes

FAQ

Why is the debug email going to the admin email address, instead of the override email address?

The debug email doesn’t provide a filter to allow changing the email address it’s being sent to. This will hopefully change in a future release of WordPress, you can follow progress in this ticket.

Rezensionen

A must have!

Very good plugin. Unfortunately there is a mistake translation in the italian version: „Update WordPress core automatically“ is translated with „Vuoi aggiornare automaticamente i plugins?“. It’s WRONG!

Works great on 4.4

Very useful plugin for sites that need to stay on top of each update for security. Hopefully the readme can be updated in order to lose the warning banner so the plugin continues to attract new users.

Lucky to find this plugin!

As I host quite a few wordpress sites, I needed a way to apply automatic updates to my core installation and plugins. I tried this plugin on several sites and it works absolutely perfect!

Highly recommended if you maintain several WordPress websites and want updates to be done automatically.

To the developer. BIG THANK YOU!!

Lies alle 50 Rezensionen

Mitwirkende & Entwickler

„Advanced Automatic Updates“ ist Open-Source-Software. Folgende Menschen haben an diesem Plugin mitgewirkt:

Mitwirkende

„Advanced Automatic Updates“ wurde in folgende 7 Sprachen übersetzt: Japanese, German, Italian, Dutch, Czech, English (Canada), English (Australia). Danke an die Übersetzerinnen und Übersetzer für ihre Mitwirkung.

Übersetze „Advanced Automatic Updates“ in deine Sprache.

Interessiert an der Entwicklung?

Durchstöbere den Code oder abonniere das Entwicklungsprotokoll per RSS.

Changelog

1.0.2

  • ADDED: Strictly disallow activation on versions of WordPress earlier than 3.7
  • CHANGED: Update filter name for redirecting debug emails (only available in WordPress 3.8+)

1.0.1

  • CHANGED: Fresh installs now disable Major updates by default, to match Core behaviour
  • UPDATED: German (de_DE) translation. Props Alexander Pfabel
  • UPDATED: Japanese (日本語) (ja) translation. Props Tai
  • UPDATED: Italian (it_IT) translation. Props Stefano Giolo
  • UPDATED: Dutch (nl_NL) translation. Props Trifon Rijksen
  • FIXED: Fresh installs had Minor updates disabled

1.0

With the release of WordPress 3.7, Automatic Updater is now know as Advanced Automatic Updates!

  • ADDED: Options to enable Major and Minor Core updates
  • ADDED: Warning in wp-admin when AUTOMATIC_UPDATER_DISABLED is set
  • ADDED: Turkish (tr_TR) translation. Props Tufan Tunç
  • CHANGED: Debug Email option now allows enabling only for dev upgrades (default)
  • UPDATED: Language POT file
  • FIXED: PHP notice in PHP 5.4+ with WP_DEBUG enabled

0.9.1

  • UPDATED: Language POT file
  • UPDATED: German (de_DE) translation. Props Alexander Pfabel
  • UPDATED: Dutch (nl_NL) translation. Props Trifon Rijksen
  • FIXED: If the svn up output was empty, don’t send an update email
  • FIXED: Removed pass-by-reference, it’s too old school for @wonderboymusic
  • FIXED: The settings link was incorrect in Multisite

0.9

  • ADDED: Warning when Better WP Security is hiding update info
  • ADDED: Warning when the user can’t update directly, but hasn’t defined S/FTP login details
  • ADDED: AUTOMATIC_UPDATER_DISABLED wp-config option, for forcing updates to never happen
  • ADDED: Sanity check to make sure the plugin isn’t accessed directly
  • CHANGED: For nightly build upgrade notification emails, include the build numbers
  • UPDATED: Tested up to WordPress 3.6
  • FIXED: Don’t send a notification email if the core upgrade didn’t change versions (ie, a nightly build with no changes)
  • FIXED: Settings page CSS wasn’t loading if the plugin was installed in a symlink directory
  • FIXED: Themes and plugins in non-writeable directories weren’t being highlighted correctly on the settings page
  • FIXED: Core upgrade retry emails were not showing the correct retry limit
  • FIXED: Nightly core upgrades can sometimes repeat more than once every 24 hours

0.8.5

  • FIXED: Disable email notifications option was being set, but not showing up as set
  • FIXED: Only write to the options table when options have actually change
  • FIXED: Funky email layout if svn up’ing multiple things in one go
  • FIXED: Possible PHP error caused by including some core class definitions multiple times

0.8.4

  • ADDED: A link to the SVN log browser for Core, when it updates
  • ADDED: Japanese (日本語) (ja) translation. Props Tai
  • UPDATED: Norwegian Bokmål (nb_NO) translation. Props Bjørn Johansen

0.8.3

  • FIXED: Bug preventing normal WordPress Core updates from occurring
  • FIXED: Theme and Plugin updates not properly skipping those marked for SVN updates

0.8.2

  • FIXED: SVN updates of WordPress core were not being triggered
  • FIXED: Particularly large SVN updates could cause notification email corruption
  • UPDATED: Dutch (nl_NL) translation. Props Trifon Rijksen
  • UPDATED: German (de_DE) translation. Props Alexander Pfabel

0.8.1

  • UPDATED: Language POT file
  • FIXED: Some unnecessary characters appearing in Admin when SVN isn’t being used
  • FIXED: Sanity checking of normal updates marked for SVN updates

0.8

  • ADDED: SVN support for plugins and themes
  • ADDED: Retry limits, so broken updates won’t keep trying to install
  • ADDED: Option to only receive SVN update emails if something went wrong
  • FIXED: Some HTML tags in debug messages were being incorrectly stripped
  • FIXED: Don’t automatically enable Core updates on installs that seem to be coming from a repo

0.7.2

  • ADDED: WordPress MultiSite support
  • UPDATED: German (de_DE) translation. Props Alexander Pfabel
  • FIXED: Now works properly if installed in a symlink directory

0.7.1

  • UPDATED: Italian (it_IT) translation. Props Stefano Giolo
  • UPDATED: Dutch (nl_NL) translation. Props Trifon Rijksen
  • FIXED: Override email setting wasn’t saving correctly

0.7

  • ADDED: Option to override where the update email is sent
  • ADDED: ‚auto_updater_notification_email_address‘ filter, for the update notification email address
  • ADDED: Reminder in the notification email for users to mark the plugins/themes compatible
  • ADDED: Option to disable notification emails
  • CHANGED: Notification emails now send as HTML emails (for greater flexibility of information to include)
  • UPDATED: Language POT file
  • FIXED: Some strings were formatted incorrectly for translation
  • FIXED: Escape all strings appropriately before displaying
  • FIXED: SVN updates would cause hourly emails, regardless of an update occurring or not

0.6.3

  • ADDED: Taiwan Traditional Chinese (Taiwan 正體中文) (zh_TW) translation. Props Pseric
  • ADDED: Italian (it_IT) translation. Props Stefano Giolo.

0.6.2

0.6.1

0.6

  • ADDED: Support for nightly builds
  • ADDED: Dutch (nl_NL) translation. Props Trifon Rijksen
  • UPDATED: Language POT file

0.5

  • ADDED: SVN support for core – if you’re running WordPress from SVN, you now have the option to keep it up-to-date!
  • ADDED: Norwegian Bokmål (nb_NO) translation. Props Bjørn Johansen
  • ADDED: Link to the Settings page from the Plugin list
  • UPDATED: Language POT file

0.4.1

  • FIXED: Stop trying to update plugins and themes that are already updated

0.4

  • ADDED: German (de_DE) translation. Props Alexander Pfabel
  • ADDED: Version check on activation, for compatibility
  • UPDATED: Language POT file
  • FIXED: Typo in the Settings page
  • FIXED: Debug information in the notification email now has HTML tags stripped out
  • FIXED: Core version check was a little too strong, and could cause updates to be missed. Relaxed a little
  • FIXED: Checking to see if WordPress has found any updates will now occur much more frequently

0.3.2

  • ADDED: Language file for translators
  • FIXED: Translations should load properly now
  • FIXED: Don’t try to update WordPress to the same version (I’m mostly certain it’s actually fixed this time)
  • FIXED: Minor formatting change to the notification emails

0.3.1

  • FIXED: Don’t try to update WordPress to the same version (harmless, but unnecessary)
  • FIXED: A PHP warning in the Settings page
  • FIXED: A couple of typos

0.3

  • ADDED: Extra update checks, updates will now occur as soon as is humanly possible
  • ADDED: Much nicer notification emails when upgrades occur
  • ADDED: Option to display debug information in the notification email
  • FIXED: Use ouput buffering to ensure nothing is printed during upgrades

0.2

  • ADDED: Some useful filters and actions. See the Documentation for details
  • FIXED: s/automattic/automatic/g
  • FIXED: Support forums link

0.1

  • Erstveröffentlichung