Checksum Verifier

Beschreibung

Checksum Verifier berechnet die MD5 Prüfsummen für alle existierenen WordPress Core Dateien und gleicht diese mit den offiziellen Prüfsummen ab. Dadurch erkennt es, wenn unbekannte Änderungen an deinem WordPress Core System vorgenommen wurden (zum Beispiel SoakSoak Malware) und kann darauf reagieren.

Checksum Verifier überprüft täglich die MD5 Prüfsummen. Falls eine unerwartete Änderungen an den Core Dateien festgestellt wurde, sendet das Plugin eine E-Mail mit einer Liste der betroffenen Dateien an den Administrator der Seite (oder Super-Admin bei WordPress Multisite). Die erste Prüfung wird bei der Aktivierung des Plugins durchgeführt. Reguläre Core Updates werden natürlich keinen Alarm auslösen. Das Plugin wird dich nur benachrichtigen, falls Core Dateien kompromittiert wurden und deine Seite möglicherweise gehackt wurde.

Checksum Verifier arbeitet als „stiller“ Hintergrunddienst und benachrichtigt dich nur, falls unerwartete Änderungen an Dateien festgestellt wurden, die möglicherweise eine Gefahr für die Core-Installation darstellen.

Verbesserte Sicherheit für WordPress.

Verwendbare Hooks

  • checksum_verifier_ignore_files
    Änderung oder Erweiterung eines array von Dateipfaden relativ zu deinem WordPress Installationspfad, welche von der Verifikation ausgeschlossen werden.
    Standard ist array('wp-config-sample.php', 'wp-includes/version.php', 'readme.html', 'readme-ja.html', 'liesmich.html', 'olvasdel.html', 'procitajme.html').

Support

Mitwirken

  • Die aktive Entwicklung dieses Plugins findet auf GitHub statt.
  • Pull-Anfragen für dokumentierte Fehler sind sehr willkommen.
  • Wenn du denkst, dass du einen Fehler gefunden hast (z.B. falls unerwartetes Verhalten auftritt), hinterlasse bitte zunächst einen Beitrag im Support-Forum.
  • Wenn du uns helfen möchtest, das Plugin zu übersetzen, kannst du dies auf WordPress Translate tun.

Danksagungen

Installation

  • Falls du nicht weißt, wie ein Plugin für WordPress installiert werden kann, bieten wir hier eine Anleitung an.

Systemanforderungen

  • WordPress 3.8 und höher
  • PHP 5.2.4 und höher

FAQ

Installationsanweisungen
  • Falls du nicht weißt, wie ein Plugin für WordPress installiert werden kann, bieten wir hier eine Anleitung an.

Systemanforderungen

  • WordPress 3.8 und höher
  • PHP 5.2.4 und höher

Rezensionen

found a virus missed by quttera

this plugin found a virus that was overlooked by both quttera and clamav. the virus was doing bitcoin mining on our server, consuming much of our resources.

thank you for providing such a useful plugin.

Lies alle 4 Rezensionen

Mitwirkende & Entwickler

„Checksum Verifier“ ist Open-Source-Software. Folgende Menschen haben an diesem Plugin mitgewirkt:

Mitwirkende

„Checksum Verifier“ wurde in 1 Sprache übersetzt. Danke an die Übersetzerinnen und Übersetzer für ihre Mitwirkung.

Übersetze „Checksum Verifier“ in deine Sprache.

Interessiert an der Entwicklung?

Durchstöbere den Code, sieh dir das SVN Repository an oder abonniere das Entwicklungsprotokoll per RSS.

Änderungsprotokoll

0.0.2

  • wp-content/ Verzeichnis von Prüfung ausgeschlossen
  • Lokalisierte readme.html Dateien von Prüfung ausgeschlossen
  • Kleinere Code-Verbesserungen
  • Explizites Setzen der maximalen Ausführzeit entfernt

0.0.1

  • Checksum Verifier nimmt seinen Betrieb auf