Code Widget

Beschreibung

Code Widget is simple widget allow you to insert any arbitrary Text/HTML and run PHP Code or Short Code. This Widget parse PHP code into simple text and much more.

Only users with the unfiltered_html role will be allowed to insert unfiltered HTML. This includes PHP code, so users without admin or editor permissions will not be able to use this to execute code, even if they have widget editing permissions.

Screenshots

  • How short code work.
  • How PHP code work.
  • How HTML Mark add.
  • How Simple Text add and how auto paragraph work.

FAQ

Short Code supported ?

Very simple add [your short code].If you want to see how short code work in this widget see screen shot.

Can we run PHP Code in this widget ?

Yes, All PHP code must be enclosed in the standard php opening and closing tags ( <?php and ?> ) for it to be recognized and executed. Please See screen shot to check how PHP Code work.

There’s some kind of error code-widget.php(188) : eval()’d code on line 6

That means your PHP code is incorrect or otherwise broken.

Can We add Simple HTML Markup ?

just simple add html markup which you want display in widget. See See Screen shot for more help.

Yes, Simple Text also Work in Code Widget ?

As our normal routine we insert any text in widget.

There is any option to add auto Paragraph tag ?

yes check widget setting if you want to add auto paragraph tag for show some beauty and cleanness.

Rezensionen

Lies alle 3 Rezensionen

Mitwirkende & Entwickler

„Code Widget“ ist Open-Source-Software. Folgende Menschen haben an diesem Plugin mitgewirkt:

Mitwirkende

„Code Widget“ wurde in 1 Sprache übersetzt. Danke an die Übersetzerinnen und Übersetzer für ihre Mitwirkung.

Übersetze „Code Widget“ in deine Sprache.

Interessiert an der Entwicklung?

Durchstöbere den Code, sieh dir das SVN Repository an oder abonniere das Entwicklungsprotokoll per RSS.

Änderungsprotokoll

1.0.3

  • Compatibility : 5.2.3 compatibility added

1.0.2

  • Bug Fix : Use of undefined constant CW_TEXT_DOMAIN
  • Compatibility : 5.0.0 compatibility added

1.0.1

  • read me update

1.0.0

  • Short Code Support Added
  • PHP Code Support Added
  • HTML Support Added
  • Simple Text Support Added
  • Auto app Paragraph check Added